aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-07-27 22:30:20 +0200
committerKhem Raj <raj.khem@gmail.com>2019-11-17 12:34:21 -0800
commit4339c28ff4aa0264c34f4f183349aea20a5ff127 (patch)
tree58e1fbf2bf2c35d6c07eaa47cd8aa6df5633d017 /meta-oe/recipes-support/libgpiod
parent599304fb377187eb900261d4eda66de39abaf664 (diff)
downloadmeta-openembedded-4339c28ff4aa0264c34f4f183349aea20a5ff127.tar.gz
libgpiod: put gpio utils into an actual separate package
Currently tools are built conditionally depending on whether the corresponding PACKAGECONFIG option has been set and, although they live in a separate libgpiod-tools package, the user cannot simply select it - he has to additionally extend PACKAGECONFIG. While this makes sense for python and C++ bindings, the tools don't have any dependencies other the libgpiod. Make libgpiod-tools an actual stand-alone package: always build them but install them only if user selected libgpiod-tools. Disable setting tools in default PACKAGECONFIGS Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> s
Diffstat (limited to 'meta-oe/recipes-support/libgpiod')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.inc6
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb3
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb4
3 files changed, 5 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc
index 89679cb919..07ce35a7f2 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod.inc
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc
@@ -8,11 +8,9 @@ SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
inherit autotools pkgconfig
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
-PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+EXTRA_OECONF = "--enable-tools"
PACKAGES =+ " ${PN}-tools"
FILES_${PN}-tools = "${bindir}/*"
-
-RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
-RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
index 3ecfffdd67..c4d2bddf4c 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.3.bb
@@ -1,7 +1,6 @@
require libgpiod.inc
-# enable tools
-PACKAGECONFIG ?= "tools"
+PACKAGECONFIG ?= ""
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb
index d559028989..0391deb86c 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.1.bb
@@ -5,8 +5,8 @@ DEPENDS += "autoconf-archive-native"
SRC_URI[md5sum] = "585b4bb431f99c4ba9b3ee58b9d494c1"
SRC_URI[sha256sum] = "21ae8fd1f8dafc2eb2ba50e652390cf533d21351419a7426255895cb52e21b1c"
-# enable tools and cxx bindings
-PACKAGECONFIG ?= "cxx tools"
+# enable cxx bindings
+PACKAGECONFIG ?= "cxx"
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"