aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgpiod
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2021-01-28 11:51:29 -0500
committerKhem Raj <raj.khem@gmail.com>2021-01-28 16:53:13 -0800
commit43560d8e225c0f77599a1141f2a1c0b60fbf1fa0 (patch)
tree67cb6de1a3a25f05887568968c390ff27663a9f9 /meta-oe/recipes-support/libgpiod
parentba4968cb68ed53d0b7f246d13557391b001bac95 (diff)
downloadmeta-openembedded-43560d8e225c0f77599a1141f2a1c0b60fbf1fa0.tar.gz
libgpiod: add ptest
Added ptest for libgpiod. Requires CONFIG_GPIO_MOCKUP kernel config to be enabled. Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libgpiod')
-rw-r--r--meta-oe/recipes-support/libgpiod/files/run-ptest12
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb14
2 files changed, 24 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libgpiod/files/run-ptest b/meta-oe/recipes-support/libgpiod/files/run-ptest
new file mode 100644
index 0000000000..4cda05d446
--- /dev/null
+++ b/meta-oe/recipes-support/libgpiod/files/run-ptest
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+testbin="gpiod-test"
+ptestdir=$(dirname "$(readlink -f "$0")")
+cd $ptestdir/tests
+
+./$testbin
+if [ $? -ne 0 ]; then
+ echo "FAIL: $testbin"
+else
+ echo "PASS: $testbin"
+fi
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
index c0cf545892..e6b6476e29 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.2.bb
@@ -4,11 +4,14 @@ AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
-SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
+SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \
+ file://run-ptest \
+"
+
SRC_URI[md5sum] = "4765470becb619fead3cdaeac61b9a77"
SRC_URI[sha256sum] = "c601e71846f5ab140c83bc757fdd62a4fda24a9cee39cc5e99c96ec2bf1b06a9"
-inherit autotools pkgconfig python3native
+inherit autotools pkgconfig python3native ptest
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2"
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
@@ -31,3 +34,10 @@ PACKAGES =+ "${PN}-python"
FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"
+
+PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp ${B}/tests/.libs/gpiod-test ${D}${PTEST_PATH}/tests/
+}