aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/links/links-x11_2.22.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-19 11:31:45 -0700
committerKhem Raj <raj.khem@gmail.com>2021-03-19 11:58:12 -0700
commit32cfee1b9f64f1f4e1581d9d8f6dcee01137964b (patch)
tree2598e38d27b7a6ffce672db95b150b01863d5329 /meta-oe/recipes-support/links/links-x11_2.22.bb
parent57f7692e8ef707535ffa1683aa711de442736ec1 (diff)
downloadmeta-openembedded-32cfee1b9f64f1f4e1581d9d8f6dcee01137964b.tar.gz
links-x11,links: Upgrade to 2.22
Remove devtool added comment Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/links/links-x11_2.22.bb')
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.22.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/links/links-x11_2.22.bb b/meta-oe/recipes-support/links/links-x11_2.22.bb
new file mode 100644
index 0000000000..563984c0eb
--- /dev/null
+++ b/meta-oe/recipes-support/links/links-x11_2.22.bb
@@ -0,0 +1,29 @@
+require links.inc
+
+DEPENDS += "virtual/libx11"
+RCONFLICTS_${PN} = "links"
+
+inherit features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI += " file://links2.desktop \
+ http://www.xora.org.uk/oe/links2.png;name=icon"
+
+SRC_URI[sha256sum] = "0364986b3a7f1e8e3171bea362b53f71e1dd3360a8842d66fdc65580ebc2084d"
+SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
+
+S = "${WORKDIR}/links-${PV}"
+
+EXTRA_OECONF = "--enable-graphics \
+ --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+ --without-libtiff --without-svgalib --without-fb \
+ --without-directfb --without-pmshell --without-atheos \
+ --with-x --without-gpm"
+
+do_install_append() {
+ install -d ${D}/${datadir}/applications
+ install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
+}