aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2016-02-23 13:45:32 -0500
committerArmin Kuster <akuster808@gmail.com>2016-04-17 12:51:53 -0700
commitf1dc4078e1bf2942218ccc2fae23db2a72afef38 (patch)
tree0f0a0b4d8a6fecbb58230cd255e0113693fd7b1c /meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
parent70ed0a32c5b858f3ae91c2f1e7c9efd66e9a13ca (diff)
downloadmeta-openembedded-f1dc4078e1bf2942218ccc2fae23db2a72afef38.tar.gz
log4cpp: Fix build system path in pkgconfig file QA failure.
* Must remove path from pc.in and stop configure.in from regenerating the file. * Also included some changes requested in earlier review that arrived late. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb')
-rw-r--r--meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
index a543044162..c7bf288fab 100644
--- a/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
+++ b/meta-oe/recipes-support/log4cpp/log4cpp_1.1.1.bb
@@ -6,9 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI[md5sum] = "1e173df8ee97205f412ff84aa93b8fbe"
SRC_URI[sha256sum] = "35abf332630a6809c969276b1d60b90c81a95daf24c86cfd7866ffef72f9bed0"
-SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz"
+SRC_URI = "http://downloads.sourceforge.net/${BPN}/${BP}.tar.gz \
+ file://fix-pc.patch;striplevel=2 \
+ "
-S="${WORKDIR}/${BPN}"
+S = "${WORKDIR}/${BPN}"
inherit autotools pkgconfig
@@ -17,5 +19,5 @@ EXTRA_OECONF = "\
--enable-dot=no \
--enable-html-docs=no \
--enable-latex-docs=no \
- LDFLAGS=-lpthread \
+ LDFLAGS=-pthread \
"