aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/maliit/maliit-framework_git.bb
diff options
context:
space:
mode:
authorSamuel Stirtzel <s.stirtzel@googlemail.com>2012-10-17 08:55:32 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-17 13:04:57 +0200
commitd9b7d6b4cd6b959b3998ddfec9775b64ffa61fe0 (patch)
treea60ad43303088281e7324b7fe1190903e12e6838 /meta-oe/recipes-support/maliit/maliit-framework_git.bb
parent0caaa82c3d7e6b4704c27ad40e37c0eb5db7048b (diff)
downloadmeta-openembedded-d9b7d6b4cd6b959b3998ddfec9775b64ffa61fe0.tar.gz
Maliit: Add initial recipes
Maliit is a Qt based virtual keyboard under liberal license (LGPLv2.1 / BSD) The inputmethod framework from Qt is used and it supports gtk-immodules. It can also be used without dependencies to GTK+ (separate package for GTK+) Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/maliit/maliit-framework_git.bb')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
new file mode 100644
index 0000000000..3f50d1bc57
--- /dev/null
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -0,0 +1,86 @@
+DESCRIPTION = "A virtual keyboard for touch-screen based user interfaces"
+HOMEPAGE = "https://wiki.maliit.org/Main_Page"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
+
+inherit autotools qt4x11
+
+
+SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
+ file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
+ file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \
+ "
+
+SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
+PV = "0.92.3+git${SRCPV}"
+
+
+PACKAGES =+ "\
+ ${PN}-gtk \
+ "
+
+# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2.
+RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4"
+
+RRECOMMENDS_${PN} = "maliit-plugins"
+
+
+FILES_${PN} += "\
+ ${libdir}/maliit/plugins-*/factories/libmaliit-plugins-quick-factory-*.so \
+ ${libdir}/qt4/plugins/inputmethods/*.so \
+ "
+
+FILES_${PN}-dbg += "\
+ ${libdir}/maliit-framework-tests \
+ ${libdir}/gtk-*/*/immodules/.debug \
+ ${libdir}/maliit/plugins-*/factories/.debug \
+ ${libdir}/qt4/plugins/.debug \
+ ${libdir}/qt4/plugins/inputmethods/.debug \
+ "
+
+FILES_${PN}-dev += "${datadir}/qt4"
+
+FILES_${PN}-gtk +="\
+ ${bindir}/maliit-exampleapp-gtk* \
+ \
+ ${libdir}/gtk-*/*/immodules/libim-maliit.so\
+ "
+
+EXTRA_QMAKEVARS_PRE = "\
+ PREFIX=${prefix} \
+ LIBDIR=${libdir} \
+ QT_IM_PLUGIN_PATH=${libdir}/qt4/plugins/inputmethods \
+ MALIIT_INSTALL_PRF=${datadir}/qt4/mkspecs/features \
+ SCHEMADIR=${sysconfdir}/gconf/schemas \
+ CONFIG+=disable-gconf \
+ CONFIG+=disable-gtk-cache-update \
+ CONFIG+=local-install \
+ "
+
+do_install() {
+ cd ${S} && (INSTALL_ROOT=${D} oe_runmake install)
+
+ #Fix absolute paths
+ cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-framework.prf
+ cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-plugins.prf
+}
+
+
+
+# Update the inputmethod modules in gtk
+pkg_postinst_${PN}-gtk() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+
+pkg_postrm_${PN}-gtk() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+
+S= "${WORKDIR}/git"