aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_161.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-11-14 01:40:24 -0800
committerArmin Kuster <akuster808@gmail.com>2018-11-18 09:54:02 -0800
commitcbdea8c9eae98633e35663135645f61d40351bc9 (patch)
tree75658d0c756fec319c6dc02a4271978ec2461eb9 /meta-oe/recipes-support/mcelog/mcelog_161.bb
parente28db69a7733e97d2b7317ae9346ab8785ecd53f (diff)
downloadmeta-openembedded-cbdea8c9eae98633e35663135645f61d40351bc9.tar.gz
mcelog: Upgrade to 161
Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_161.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_161.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_161.bb b/meta-oe/recipes-support/mcelog/mcelog_161.bb
new file mode 100644
index 0000000000..dfca3855bf
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog_161.bb
@@ -0,0 +1,35 @@
+SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
+DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
+and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
+and should run on all Linux systems that need error handling."
+HOMEPAGE = "http://mcelog.org/"
+SECTION = "System Environment/Base"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
+ file://run-ptest \
+"
+
+SRCREV = "6ed93e30f83519b0ab71f8ecd156b8ff0b2912b6"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep ptest
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
+ sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
+ sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
+}
+
+RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"