aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mime-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-support/mime-support
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mime-support')
-rw-r--r--meta-oe/recipes-support/mime-support/mime-support_3.62.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/mime-support/mime-support_3.62.bb b/meta-oe/recipes-support/mime-support/mime-support_3.62.bb
index 858521b65f..46def2a23c 100644
--- a/meta-oe/recipes-support/mime-support/mime-support_3.62.bb
+++ b/meta-oe/recipes-support/mime-support/mime-support_3.62.bb
@@ -1,14 +1,14 @@
SECTION = "base"
SUMMARY = "MIME files 'mime.types' & 'mailcap', and support programs"
LICENSE = "PD & Bellcore"
-LICENSE_${PN} = "PD"
+LICENSE:${PN} = "PD"
# mailcap.man's license is Bellcore
-LICENSE_${PN}-doc = "PD & Bellcore"
+LICENSE:${PN}-doc = "PD & Bellcore"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=53c851e31d27c3ea8a6217073a5ff01c"
DEPENDS = "file"
-RDEPENDS_${PN} = "perl"
-RRECOMMENDS_${PN} = "file"
+RDEPENDS:${PN} = "perl"
+RRECOMMENDS:${PN} = "file"
SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}.tar.gz"
SRC_URI[sha256sum] = "54e0a03e0cd63c7c9fe68a18ead0a2143fd3c327604215f989d85484d0409f4a"
@@ -16,9 +16,9 @@ S = "${WORKDIR}/${BPN}"
inherit update-alternatives
-FILES_${PN} += " ${libdir}/mime"
+FILES:${PN} += " ${libdir}/mime"
-docdir_append = "/${BPN}"
+docdir:append = "/${BPN}"
do_install () {
install -d ${D}${sysconfdir}
@@ -61,5 +61,5 @@ do_install () {
}
ALTERNATIVE_PRIORITY = "90"
-ALTERNATIVE_${PN} = "mime.types"
+ALTERNATIVE:${PN} = "mime.types"
ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types"