aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-07-26 17:23:12 +0800
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:42 -0700
commitae7f8f79c37de19bb2e17024cf2bf4f5e09bd12b (patch)
treecb116705148d8366900b0f2ddd279e1b493b78b2 /meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb
parent4756aea459ce1ab895fd29a607557ec4fb77fa63 (diff)
downloadmeta-openembedded-ae7f8f79c37de19bb2e17024cf2bf4f5e09bd12b.tar.gz
mariadb: upgrade to 5.5.50
Upgrade mariadb from 5.5.46 to 5.5.50. * update runtime dependency of mariadb-setupdb which requires command install [AK] This update appears to be mostly bug fixes and is why is was merge from master. plus the following securiy fixes 5.5.49: CVE-2016-0647 CVE-2016-0648 CVE-2016-0666 CVE-2016-0643 CVE-2016-5444 CVE-2016-3452 5.5.48: CVE-2016-0640 CVE-2016-0644 CVE-2016-0646 CVE-2016-0649 CVE-2016-0650 CVE-2016-0641 5.5.47: CVE-2016-0546 CVE-2016-0505 CVE-2016-0596 CVE-2016-0597 CVE-2016-0616 CVE-2016-0598 CVE-2016-0600 CVE-2016-0606 CVE-2016-0608 CVE-2016-0609 CVE-2016-0642 CVE-2016-0651 CVE-2016-2047 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 6255219b93d2af4cf56611fb5b1c3dc55ada2c6b) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb
new file mode 100644
index 0000000000..4ce960d7da
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.5.50.bb
@@ -0,0 +1,19 @@
+require mariadb.inc
+inherit native
+
+PROVIDES += "mysql5-native"
+DEPENDS = "ncurses-native zlib-native bison-native"
+
+RDEPENDS_${PN} = ""
+PACKAGES = ""
+EXTRA_OEMAKE = ""
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+
+ install -d ${D}${bindir}
+ install -m 0755 sql/gen_lex_hash ${D}${bindir}/
+ install -m 0755 extra/comp_err ${D}${bindir}/
+ install -m 0755 scripts/comp_sql ${D}${bindir}/
+}
+