aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2014-11-18 17:54:38 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-11-24 12:01:53 +0100
commitc636aae61fe9681276bda09d135454cfa598aa0b (patch)
tree59685bef0892a6b6447e6f433dede7c5078be8d1 /meta-oe/recipes-support/mysql
parent66e9c19579def6551fd750f82a9695b06b5eb596 (diff)
downloadmeta-openembedded-c636aae61fe9681276bda09d135454cfa598aa0b.tar.gz
mariadb: add dependency libevent
mariadb failed to build: | make[2]: *** No rule to make target '/.../bitbake_build/tmp/sysroots/qemux86-64/usr/lib64/libevent.so', needed by 'tests/async_queries'. Stop. | make[2]: Leaving directory '/.../bitbake_build/tmp/work/core2-64-wrs-linux/mariadb/5.5.40-r0/build' CMakeFiles/Makefile2:6742: recipe for target 'tests/CMakeFiles/async_queries.dir/all' failed | make[1]: *** [tests/CMakeFiles/async_queries.dir/all] Error 2 It is an rare case that when configure mariadb, libevent exists in sysroot. But when do compile for mariadb, libevent is gone somehow. That causes build fails. Run follow commands could reproduce this error: $ bitbake libevent $ bitbake mariadb -c cleansstate $ bitbake mariadb -c configure $ bitbake libevent -c clean $ bitbake mariadb Add if without libevent, test case tests/async_queries.c will not be built. The case is helpful to do unit test. So add libevent as a dependency to fix the error and make sure async_queries.c will be built. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mysql')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb_5.5.40.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb_5.5.40.bb b/meta-oe/recipes-support/mysql/mariadb_5.5.40.bb
index f24cb4346f..8f998a3a56 100644
--- a/meta-oe/recipes-support/mysql/mariadb_5.5.40.bb
+++ b/meta-oe/recipes-support/mysql/mariadb_5.5.40.bb
@@ -2,7 +2,7 @@ require mariadb.inc
EXTRA_OECMAKE += "-DSTACK_DIRECTION=-1"
-DEPENDS += "mariadb-native ncurses zlib readline libaio"
+DEPENDS += "mariadb-native ncurses zlib readline libaio libevent"
PROVIDES += "mysql5"