aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nss
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-27 16:23:40 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-27 16:29:23 -0700
commit9bbe3ff10256b7ccee6d2157cbb395a80874ee52 (patch)
tree879f5c672441af9c402c405bc38268c5b8b1735d /meta-oe/recipes-support/nss
parent26de7600bdcfbb7c9333b15868f954ca028b81a9 (diff)
downloadmeta-openembedded-9bbe3ff10256b7ccee6d2157cbb395a80874ee52.tar.gz
nss: Disable Werror across all recipe types
We are seeing warnigs with gcc-10 even on target builds e.g. | In file included from nsinstall.c:20: | /usr/include/unistd.h:520:14: note: in a call to function ‘getcwd’ declared with attribute ‘write_only (1, 2)’ | 520 | extern char *getcwd (char *__buf, size_t __size) __THROW __wur | | ^~~~~~ | nsinstall.c:70:16: error: argument 1 is null but the corresponding size argument 2 value is 4096 [-Werror=nonnull] | 70 | #define GETCWD getcwd | | ^ | nsinstall.c:246:13: note: in expansion of macro ‘GETCWD’ | 246 | todir = GETCWD(0, PATH_MAX); | | ^~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/nss')
-rw-r--r--meta-oe/recipes-support/nss/nss_3.54.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.54.bb b/meta-oe/recipes-support/nss/nss_3.54.bb
index 882145c1ef..1cc94735bb 100644
--- a/meta-oe/recipes-support/nss/nss_3.54.bb
+++ b/meta-oe/recipes-support/nss/nss_3.54.bb
@@ -58,7 +58,6 @@ do_configure_prepend_libc-musl () {
do_compile_prepend_class-native() {
export NSPR_INCLUDE_DIR=${STAGING_INCDIR_NATIVE}/nspr
export NSPR_LIB_DIR=${STAGING_LIBDIR_NATIVE}
- export NSS_ENABLE_WERROR=0
}
do_compile_prepend_class-nativesdk() {
@@ -72,6 +71,7 @@ do_compile_prepend_class-native() {
do_compile() {
export NSPR_INCLUDE_DIR=${STAGING_INCDIR}/nspr
+ export NSS_ENABLE_WERROR=0
export CROSS_COMPILE=1
export NATIVE_CC="${BUILD_CC}"