aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nss
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-09-02 00:41:41 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-01 20:24:44 -0700
commit9f0a83f9afb984e09740f1bda4c5baf6fff6e3e2 (patch)
tree5c9fa4ba25092cbe62040b109218514611c0caf3 /meta-oe/recipes-support/nss
parent1412471631ff0fb530f0babcf695ad6ef2f0e9a5 (diff)
downloadmeta-openembedded-9f0a83f9afb984e09740f1bda4c5baf6fff6e3e2.tar.gz
nss: remove signlibs.sh
Looks like my "solution" also isn't working well at least for images with read-only-rootfs in IMAGE_FEATURES. pkg_postinst_ontarget_${PN} is always forced to run on the target, which for read-only-rootfs results in: log.do_rootfs: ... NOTE: If an image is being built, the postinstalls for the following packages will be postponed for first boot: nss ... ERROR: The following packages could not be configured offline and rootfs is read-only: ['nss'] and now looking at the /usr/bin/signlibs.sh and it does pretty much the same as the postinst script when D isn't empty. >From oe-core git history it shows that signlibs.sh was added first: https://git.openembedded.org/openembedded-core/commit/?id=a4580f967c8064294a06d406acf5deb24aee2acc then the offline version of postinst was added to support read-only-rootfs in: https://git.openembedded.org/openembedded-core/commit/?id=64e87fc6e99bc1d4807034166735034b1f92bad8 and nss-native should always provide the shlibsign since: https://git.openembedded.org/openembedded-core/commit/?id=88540c5b08dea069660d1a68e506aebdd68e6ae0 and only after https://git.openembedded.org/openembedded-core/commit/?id=8f782f7095e718dd9452055af53363beb6bdbece it looked like signlibs.sh was something special only for target. So it looks to me, that we should just remove signlibs.sh script and let the same postinst be used on target and offline (with or without D being empty). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/nss')
-rw-r--r--meta-oe/recipes-support/nss/nss/signlibs.sh20
-rw-r--r--meta-oe/recipes-support/nss/nss_3.56.bb6
2 files changed, 0 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/nss/nss/signlibs.sh b/meta-oe/recipes-support/nss/nss/signlibs.sh
deleted file mode 100644
index a74e499f8c..0000000000
--- a/meta-oe/recipes-support/nss/nss/signlibs.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-# signlibs.sh
-#
-# (c)2010 Wind River Systems, Inc.
-#
-# regenerates the .chk files for the NSS libraries that require it
-# since the ones that are built have incorrect checksums that were
-# calculated on the host where they really need to be done on the
-# target
-
-CHK_FILES=`ls /lib*/*.chk /usr/lib*/*.chk 2>/dev/null`
-SIGN_BINARY=`which shlibsign`
-for I in $CHK_FILES
-do
- DN=`dirname $I`
- BN=`basename $I .chk`
- FN=$DN/$BN.so
- $SIGN_BINARY -i $FN
-done
diff --git a/meta-oe/recipes-support/nss/nss_3.56.bb b/meta-oe/recipes-support/nss/nss_3.56.bb
index 107b0a0152..997f8950fd 100644
--- a/meta-oe/recipes-support/nss/nss_3.56.bb
+++ b/meta-oe/recipes-support/nss/nss_3.56.bb
@@ -21,7 +21,6 @@ VERSION_DIR = "${@d.getVar('BP').upper().replace('-', '_').replace('.', '_') + '
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${VERSION_DIR}/src/${BP}.tar.gz \
file://nss.pc.in \
- file://signlibs.sh \
file://0001-nss-fix-support-cross-compiling.patch \
file://nss-no-rpath-for-cross-compiling.patch \
file://nss-fix-incorrect-shebang-of-perl.patch \
@@ -214,7 +213,6 @@ do_install_append() {
touch ${D}/${libdir}/$file
chmod 755 ${D}/${libdir}/$file
done
- install -D -m 755 ${WORKDIR}/signlibs.sh ${D}/${bindir}/signlibs.sh
install -d ${D}${libdir}/pkgconfig/
sed 's/%NSS_VERSION%/${PV}/' ${WORKDIR}/nss.pc.in | sed 's/%NSPR_VERSION%/4.9.2/' > ${D}${libdir}/pkgconfig/nss.pc
@@ -251,10 +249,6 @@ pkg_postinst_${PN} () {
done
}
-pkg_postinst_ontarget_${PN} () {
- ${bindir}/signlibs.sh
-}
-
PACKAGES =+ "${PN}-smime"
FILES_${PN}-smime = "\
${bindir}/smime \