aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-08 14:11:21 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-08 14:47:40 +0100
commitdd7c7f11049ecc4eb6cf898059d2dca2766c8408 (patch)
tree8edc4a47ce14641c89e2af104fe490b01a526ccf /meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
parent932a7a618904d1ffca864c59335c173d0852a69e (diff)
downloadmeta-openembedded-dd7c7f11049ecc4eb6cf898059d2dca2766c8408.tar.gz
ntp 4.2.6p3: add native systemd support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb')
-rw-r--r--meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb29
1 files changed, 22 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
index 590eed15a8..e2bb1a8061 100644
--- a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
+++ b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
@@ -1,13 +1,20 @@
require ntp.inc
-PR = "r2"
+PR = "r3"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE_${PN}-systemd = "ntpd.service"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
file://tickadj.c.patch \
file://ntp-4.2.4_p6-nano.patch \
file://ntpd \
file://ntp.conf \
- file://ntpdate"
+ file://ntpdate \
+ file://ntpd.service \
+"
SRC_URI[md5sum] = "59876a9009b098ff59767ee45a88ebd2"
SRC_URI[sha256sum] = "6e84d4ddfa14b911c3ed88463af10867e1fa9b287e7b34d8a02e78be85a7c40e"
@@ -15,13 +22,21 @@ SRC_URI[sha256sum] = "6e84d4ddfa14b911c3ed88463af10867e1fa9b287e7b34d8a02e78be85
EXTRA_OECONF += " --with-net-snmp-config=no --without-ntpsnmpd"
do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir}
- install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
- install -d ${D}/${sysconfdir}/network/if-up.d
- install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir}
+ install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
+
+ install -d ${D}${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/ntpd.service ${D}${base_libdir}/systemd/system/
}
+PACKAGES =+ "${PN}-systemd"
+
+FILES_${PN}-systemd = "${base_libdir}/systemd/system/"
+RDEPENDS_${PN}-systemd = "${PN}"
+
FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
FILES_${PN}-tickadj = "${bindir}/tickadj"