aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 15:50:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:33:24 +0100
commit37a841321dca1314c9844d8d4665b5ff1e28a40f (patch)
treefa18605b97edc9ae7517f0e06489e88e661f5b1e /meta-oe/recipes-support/synergy/synergy_1.3.8.bb
parent20a624928c030fa13d8b7d45b4f4d7e1ac624f60 (diff)
downloadmeta-openembedded-37a841321dca1314c9844d8d4665b5ff1e28a40f.tar.gz
recipes: add x11 to required DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/synergy/synergy_1.3.8.bb')
-rw-r--r--meta-oe/recipes-support/synergy/synergy_1.3.8.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
index 642845f967..45c0bc2f52 100644
--- a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
+++ b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9772a11e3569985855e2ce450e56f991"
LICENSE = "GPL-2.0"
SECTION = "x11/utils"
-DEPENDS = "libx11 libxtst libxinerama"
+DEPENDS = "virtual/libx11 libxtst libxinerama"
SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz"
@@ -13,7 +13,9 @@ SRC_URI[sha256sum] = "0afc83e4ed0b46ed497d4229b2b2854e8d3c581a112f4da05110943edb
S = "${WORKDIR}/${PN}-${PV}-Source"
-inherit cmake
+inherit cmake distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
do_install() {
install -d ${D}/usr/bin