aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/uim
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-16 09:23:18 -0700
committerArmin Kuster <akuster808@gmail.com>2020-05-28 21:23:56 -0700
commit86cc412d8fc2006719908fece653bc11b9c3f6c5 (patch)
treed8f3c02900d29351b90a504dfb9996a668a3dfaa /meta-oe/recipes-support/uim
parent716cd27ec045f82929d0c2c3b976286481a57388 (diff)
downloadmeta-openembedded-86cc412d8fc2006719908fece653bc11b9c3f6c5.tar.gz
uim: Add patch to fix -fno-common link error
This is unearthed by gcc10 like below | /mnt/b/yoe/master/build/tmp/hosttools/ld: .libs/gcroots.o:(.bss+0x0): multiple definition of `GCROOTS_jmp_buf'; .libs/mark.o:(.bss+0x0): first defined here | /mnt/b/yoe/master/build/tmp/hosttools/ld: .libs/mach_dep.o:(.bss+0x0): multiple definition of `GCROOTS_jmp_buf'; .libs/mark.o:(.bss+0x0): first defined here | collect2: error: ld returned 1 exit status Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 5c6f6797047d5d3fdf6d84c2d7fe441ed8eb89b6) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/uim')
-rw-r--r--meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch15
-rw-r--r--meta-oe/recipes-support/uim/uim_1.8.8.bb1
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch b/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch
new file mode 100644
index 0000000000..adb9c4b06b
--- /dev/null
+++ b/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch
@@ -0,0 +1,15 @@
+Fix error pointed out by gcc10
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/sigscheme/libgcroots/include/private/gc_priv.h
++++ b/sigscheme/libgcroots/include/private/gc_priv.h
+@@ -2026,7 +2026,7 @@ void GC_err_puts(const char *s);
+
+ # if defined(NEED_FIND_LIMIT) || \
+ defined(USE_PROC_FOR_LIBRARIES) && defined(THREADS)
+-JMP_BUF GC_jmp_buf;
++extern JMP_BUF GC_jmp_buf;
+
+ /* Set up a handler for address faults which will longjmp to */
+ /* GC_jmp_buf; */
diff --git a/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-oe/recipes-support/uim/uim_1.8.8.bb
index 0366ad85ae..507a341445 100644
--- a/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -6,6 +6,7 @@ SECTION = "inputmethods"
SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+ file://JMP_BUF_GC_jmp_buf.patch \
"
SRC_URI_append_class-target = "\
file://uim-module-manager.patch \