aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-08-22 10:27:16 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:35 +0200
commit2892bd69faf94a41870c6e1330dafcb7dab974c9 (patch)
treedbfe61a663c183f65b93a357d827f6c0b588ce5e /meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers
parentfef7b1feb79c7b43623760e2cdf4e68bd0dbd526 (diff)
downloadmeta-openembedded-2892bd69faf94a41870c6e1330dafcb7dab974c9.tar.gz
vboxguestdrivers: Add recipe for vbox 5.x
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers')
-rw-r--r--meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
index 3749b95add..495601f08f 100644
--- a/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
+++ b/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
@@ -10,8 +10,10 @@
##
## -----------------------------------------------------------------------
-INCLUDES = -I. -I../vboxsf
-CFLAGS = ${INCLUDES}
+INCLUDES = -I. -I../vboxsf -I../vboxsf/include
+MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
+ -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
+CFLAGS = ${INCLUDES} ${MOD_DEFS}
LDFLAGS =
SRCS = mount.vboxsf.c \