aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xdelta
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-02-24 15:40:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-11 14:58:49 +0100
commit92e26f5f69d8918c1e37890c07e2691febed4a2b (patch)
tree4815b1ce9868990694008b0c96a85709ddcb1d86 /meta-oe/recipes-support/xdelta
parentfef89c60f381d52ddcbcf557b4082ed46233906c (diff)
downloadmeta-openembedded-92e26f5f69d8918c1e37890c07e2691febed4a2b.tar.gz
xdelta3: add new recipe for version 3.0.8
Useful command line tool for handling binary diff. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xdelta')
-rw-r--r--meta-oe/recipes-support/xdelta/files/compilation-fix.patch29
-rw-r--r--meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb15
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xdelta/files/compilation-fix.patch b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch
new file mode 100644
index 0000000000..377a0436d3
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/files/compilation-fix.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+http://code.google.com/p/xdelta/issues/detail?id=174
+
+Compilation fix:
+<code>
+| testing/regtest.cc:763:3: error: no matching function for call to 'max(xoff_t, size_t&)'
+</code>
+
+Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
+---
+ testing/regtest.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testing/regtest.cc b/testing/regtest.cc
+index 12b712e..b63a1f9 100644
+--- a/testing/regtest.cc
++++ b/testing/regtest.cc
+@@ -12,7 +12,7 @@ public:
+ Options() : encode_srcwin_maxsz(1<<20),
+ block_size(Constants::BLOCK_SIZE),
+ size_known(false) { }
+- size_t encode_srcwin_maxsz;
++ xoff_t encode_srcwin_maxsz;
+ size_t block_size;
+ bool size_known;
+ };
+--
+1.8.5.4
+
diff --git a/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
new file mode 100644
index 0000000000..16a72ee8ee
--- /dev/null
+++ b/meta-oe/recipes-support/xdelta/xdelta3_3.0.8.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Xdelta is a tool for differential compression"
+DESCRIPTION = "Open-source binary diff, differential compression tools, \
+ VCDIFF (RFC 3284) delta compression."
+HOMEPAGE = "http://xdelta.org/"
+SECTION = "console/utils"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+
+SRC_URI = "http://xdelta.googlecode.com/files/${BPN}-${PV}.tar.xz \
+ file://compilation-fix.patch"
+SRC_URI[md5sum] = "c3ae3286ce4193de8e03d5bcaccf3bc3"
+SRC_URI[sha256sum] = "3a86f29c95664fb44b8a40ff22d9bcc3e87aa8c01f0ff75931a7fa78ed3d2e55"
+
+inherit autotools