aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2013-03-13 21:23:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-18 16:31:33 +0100
commitb55fbf81bed5d56ce4592abed9210f27870f096f (patch)
tree2583c0b79a67af8e2e7138253867df0aa83b4a8a /meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8
parent19eb91d66d5ec899a781a14f3b9b50469d741d89 (diff)
downloadmeta-openembedded-b55fbf81bed5d56ce4592abed9210f27870f096f.tar.gz
xfsprogs: fix compile with uclibc
Uclibc doesn't have aio.h, which xfsprogs checks for. However, xfsprogs doesn't use aio. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8')
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch b/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch
new file mode 100644
index 0000000000..a1c60424ad
--- /dev/null
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs-3.1.8/drop-configure-check-for-aio.patch
@@ -0,0 +1,99 @@
+Upstream-Status: Pending
+
+From a38bf800a655ea32cbddd6504e15c2f18597fd13 Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Wed, 13 Mar 2013 14:40:13 +0100
+Subject: [PATCH] xfsprogs: drop configure check for aio
+
+It's unused and breaks compilation with uclibc.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+---
+ configure.in | 6 +++---
+ m4/Makefile | 1 -
+ m4/package_aiodev.m4 | 37 -------------------------------------
+ 3 files changed, 3 insertions(+), 41 deletions(-)
+ delete mode 100644 m4/package_aiodev.m4
+
+diff --git a/configure.in b/configure.in
+index 664c0e9..f7d35f1 100644
+--- a/configure.in
++++ b/configure.in
+@@ -46,6 +46,9 @@ AC_ARG_ENABLE(lib64,
+ enable_lib64=yes)
+ AC_SUBST(enable_lib64)
+
++librt="-lrt"
++AC_SUBST(librt)
++
+ #
+ # If the user specified a libdir ending in lib64 do not append another
+ # 64 to the library names.
+@@ -91,9 +94,6 @@ AC_PACKAGE_GLOBALS(xfsprogs)
+ AC_PACKAGE_UTILITIES(xfsprogs)
+ AC_MULTILIB($enable_lib64)
+
+-AC_PACKAGE_NEED_AIO_H
+-AC_PACKAGE_NEED_LIO_LISTIO
+-
+ AC_PACKAGE_NEED_UUID_H
+ AC_PACKAGE_NEED_UUIDCOMPARE
+
+diff --git a/m4/Makefile b/m4/Makefile
+index 654a4fb..d282f0a 100644
+--- a/m4/Makefile
++++ b/m4/Makefile
+@@ -14,7 +14,6 @@ CONFIGURE = \
+
+ LSRCFILES = \
+ manual_format.m4 \
+- package_aiodev.m4 \
+ package_blkid.m4 \
+ package_globals.m4 \
+ package_libcdev.m4 \
+diff --git a/m4/package_aiodev.m4 b/m4/package_aiodev.m4
+deleted file mode 100644
+index 490d9c8..0000000
+--- a/m4/package_aiodev.m4
++++ /dev/null
+@@ -1,37 +0,0 @@
+-#
+-# Check if we have a libaio.h installed
+-#
+-AC_DEFUN([AC_PACKAGE_WANT_AIO],
+- [ AC_CHECK_HEADERS(libaio.h, [ have_aio=true ], [ have_aio=false ])
+- AC_SUBST(have_aio)
+- ])
+-
+-#
+-# Check if we have an aio.h installed
+-#
+-AC_DEFUN([AC_PACKAGE_NEED_AIO_H],
+- [ AC_CHECK_HEADERS(aio.h)
+- if test $ac_cv_header_aio_h = no; then
+- echo
+- echo 'FATAL ERROR: could not find a valid <aio.h> header.'
+- exit 1
+- fi
+- ])
+-
+-#
+-# Check if we have the lio_listio routine in either libc/librt
+-#
+-AC_DEFUN([AC_PACKAGE_NEED_LIO_LISTIO],
+- [ AC_CHECK_FUNCS(lio_listio)
+- if test $ac_cv_func_lio_listio = yes; then
+- librt=""
+- else
+- AC_CHECK_LIB(rt, lio_listio,, [
+- echo
+- echo 'FATAL ERROR: could not find a library with lio_listio.'
+- exit 1],[-lpthread])
+- librt="-lrt"
+- fi
+- AC_SUBST(librt)
+- ])
+-
+--
+1.7.10.4
+