aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2011-12-28 05:56:17 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-05 10:17:02 +0100
commit9cc211194f0b43bc651b1b06c4128000fd867e02 (patch)
treeb366008afd0fb14434b71ace61be6922d7844ae3 /meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
parent42d6f4f36696faaf0e526b14bcc6daff51ab943b (diff)
downloadmeta-openembedded-9cc211194f0b43bc651b1b06c4128000fd867e02.tar.gz
xfsprogs: add version 3.1.7
xfsprogs provides XFS filesystem utilities. Signed-off-by: Zhenhua Luo <b19537@freescale.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb')
-rw-r--r--meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
new file mode 100644
index 0000000000..3830887295
--- /dev/null
+++ b/meta-oe/recipes-support/xfsprogs/xfsprogs_3.1.7.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "XFS Filesystem Utilities"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+SECTION = "base"
+LICENSE = "LGPL2.1"
+
+LIC_FILES_CHKSUM = "file://Makefile;endline=3;md5=def2844770bb44eba37bc9ca8610fad4"
+
+DEPENDS = "util-linux"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \
+ file://remove-install-as-user.patch \
+"
+SRC_URI[md5sum] = "049cf9873794ea49d0bb3f12d45748a4"
+SRC_URI[sha256sum] = "e150914210ac5fd29c098ef0fd94bdec51d2fb231cf9faa765c16ec6d75c8eaa"
+
+inherit autotools
+
+FILES_${PN}-dev += "${base_libdir}/libhandle.la \
+ ${base_libdir}/libhandle.so"
+
+EXTRA_OECONF = "--enable-gettext=no"
+do_configure () {
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+TARGET_CC_ARCH += "${LDFLAGS}"
+PARALLEL_MAKE = ""
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+ # needed for xfsdump
+ oe_runmake install-dev
+ # replace extra links to /usr/lib with relative links (otherwise autotools_prepackage_lamangler fails to read nonexistent link)
+ rm -f ${D}/${base_libdir}/libhandle.la
+ rm -f ${D}/${base_libdir}/libhandle.a
+ ln -s ../usr/lib/libhandle.la ${D}/${base_libdir}/libhandle.la
+ ln -s ../usr/lib/libhandle.a ${D}/${base_libdir}/libhandle.a
+
+ # and link from /usr/lib/libhandle.so to /lib/libhandle.so
+ rm -f ${D}/${libdir}/libhandle.so
+ ln -s ../../lib/libhandle.a ${D}/${libdir}/libhandle.so
+}