aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/xxhash
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-01-18 17:28:49 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-19 02:20:58 -0800
commit4e8cc2810ee59823604a1e1e1de2b1ada8ac92fb (patch)
treea0c5c09915420886f16c6811a57d5d28782eaae0 /meta-oe/recipes-support/xxhash
parent60e083f798c83ef6d92c298a05e2ab353d27e0de (diff)
downloadmeta-openembedded-4e8cc2810ee59823604a1e1e1de2b1ada8ac92fb.tar.gz
xxhash: Add recipe
xxHash is an extremely fast non-cryptographic hash algorithm, working at speeds close to RAM limits. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/xxhash')
-rw-r--r--meta-oe/recipes-support/xxhash/xxhash_0.7.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/xxhash/xxhash_0.7.2.bb b/meta-oe/recipes-support/xxhash/xxhash_0.7.2.bb
new file mode 100644
index 0000000000..df106e4a5a
--- /dev/null
+++ b/meta-oe/recipes-support/xxhash/xxhash_0.7.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Extremely fast non-cryptographic hash algorithm"
+DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
+working at speeds close to RAM limits."
+HOMEPAGE = "http://www.xxhash.com/"
+LICENSE = "BSD-2-Clause & GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ed3511a67991a5923907dff2ed268026"
+
+SRC_URI = "git://github.com/Cyan4973/xxHash.git"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+SRCREV = "e2f4695899e831171ecd2e780078474712ea61d3"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+ oe_runmake all
+}
+
+do_install () {
+ oe_runmake DESTDIR=${D} install
+}