aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-02-23 15:48:59 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-23 16:46:33 +0100
commita3d2fd535a2b64d94903ad2127aac103bef02b82 (patch)
treed3e18c1adc7c162f85705aa55eac8f8eb5d663d7 /meta-oe/recipes-support
parentaa26673c83a126732d9a404bbe748b7e5321009f (diff)
downloadmeta-openembedded-a3d2fd535a2b64d94903ad2127aac103bef02b82.tar.gz
ntp: use systemd_unitdir variable
* maybe we should move systemd_unitdir definition outside systemd.bbclass because it's used in few more recipes which doesn't inherit systemd Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
index 063d82a877..ece87207ff 100644
--- a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
+++ b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
@@ -1,6 +1,6 @@
require ntp.inc
-PR = "r4"
+PR = "r5"
inherit systemd
@@ -29,14 +29,14 @@ do_install_append() {
install -d ${D}/${sysconfdir}/network/if-up.d
install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
- install -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/ntpdate.service ${D}${base_libdir}/systemd/system/
- install -m 0644 ${WORKDIR}/ntpd.service ${D}${base_libdir}/systemd/system/
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
}
PACKAGES =+ "${PN}-systemd"
-FILES_${PN}-systemd = "${base_libdir}/systemd/system/"
+FILES_${PN}-systemd = "${systemd_unitdir}/system/"
RDEPENDS_${PN}-systemd = "${PN}"
FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"