aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-03-11 16:42:05 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-11 08:58:57 -0700
commitd178745cbf5c97b7cdcf274108a58c8e1f88d3ca (patch)
treeab1cf2f60e724eeecbfbf4a6c1973c4b5fee2c65 /meta-oe/recipes-support
parentf5d2bf55a8169a9446c2f96f327b3e5d91a6e6cc (diff)
downloadmeta-openembedded-d178745cbf5c97b7cdcf274108a58c8e1f88d3ca.tar.gz
conf/layer.conf: add BBFILES_DYNAMIC and dynamic layers
some recipes under meta-oe have dependency on meta-python, and test_world of yocto-check-layer will failed with error like: ERROR: test_world (common.CommonCheckLayer) ERROR: Nothing PROVIDES 'python3-pytoml-native' (but /meta-openembedded/meta-oe/recipes-extended/mozjs/mozjs_60.9.0.bb DEPENDS on or otherwise requires it). Close matches: python3-numpy-native python3-pycairo-native python3-rpm-native ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'mozjs', 'python3-pytoml-native'] fix by make these recipes only active when identified layers are present Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/smem/smem/0001-smem-fix-support-for-source-option-python3.patch53
-rw-r--r--meta-oe/recipes-support/smem/smem_1.5.bb43
2 files changed, 0 insertions, 96 deletions
diff --git a/meta-oe/recipes-support/smem/smem/0001-smem-fix-support-for-source-option-python3.patch b/meta-oe/recipes-support/smem/smem/0001-smem-fix-support-for-source-option-python3.patch
deleted file mode 100644
index 5c1be5a0a2..0000000000
--- a/meta-oe/recipes-support/smem/smem/0001-smem-fix-support-for-source-option-python3.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 3ff78f1f00973393d1a7ee4e467a2bacf1c807f3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <git@andred.net>
-Date: Wed, 5 Feb 2020 16:14:21 +0000
-Subject: [PATCH] smem: fix support for --source option (python3)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Using --source doesn't work without this patch:
-Traceback (most recent call last):
- File "./smem", line 727, in <module>
- showpids()
- File "./smem", line 299, in showpids
- showtable(pt.keys(), fields, columns.split(), options.sort or 'pss')
- File "./smem", line 519, in showtable
- mt = totalmem()
- File "./smem", line 118, in totalmem
- _totalmem = memory()['memtotal']
- File "./smem", line 193, in memory
- m = f.match(l)
-TypeError: cannot use a string pattern on a bytes-like object
-
-python3's tarfile returns bytes, whereas all of the rest of
-the code assumes str.
-
-Fix the tarfile usage to convert to str before returning the
-results.
-
-Signed-off-by: André Draszik <git@andred.net>
-Upstream-Status: Inappropriate [upstream wants to support python2 & python3]
----
- smem | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/smem b/smem
-index 46a3189..54d40dd 100755
---- a/smem
-+++ b/smem
-@@ -90,9 +90,9 @@ class tardata(procdata):
- d,f = ti.name.split('/')
- yield d
- def _read(self, f):
-- return self.tar.extractfile(f).read()
-+ return self.tar.extractfile(f).read().decode()
- def _readlines(self, f):
-- return self.tar.extractfile(f).readlines()
-+ return [l.decode() for l in self.tar.extractfile(f).readlines()]
- def piduser(self, p):
- t = self.tar.getmember("%d" % p)
- if t.uname:
---
-2.23.0.rc1
-
diff --git a/meta-oe/recipes-support/smem/smem_1.5.bb b/meta-oe/recipes-support/smem/smem_1.5.bb
deleted file mode 100644
index 90db9c3f3e..0000000000
--- a/meta-oe/recipes-support/smem/smem_1.5.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "Report application memory usage in a meaningful way"
-DESCRIPTION = "smem is a tool that can give numerous reports on memory usage on Linux \
-systems. Unlike existing tools, smem can report proportional set size (PSS), \
-which is a more meaningful representation of the amount of memory used by \
-libraries and applications in a virtual memory system."
-HOMEPAGE = "http://www.selenic.com/smem/"
-SECTION = "Applications/System"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-HG_CHANGESET = "98273ce331bb"
-SRC_URI = "https://selenic.com/repo/${BPN}/archive/${HG_CHANGESET}.tar.bz2;downloadfilename=${BP}.tar.bz2 \
- file://0001-smem-fix-support-for-source-option-python3.patch"
-SRC_URI[md5sum] = "51c3989779360f42b42ef46b2831be3a"
-SRC_URI[sha256sum] = "161131c686a6d9962a0e96912526dd46308e022d62e3f8acaed5a56fda8e08ce"
-
-UPSTREAM_CHECK_URI = "https://selenic.com/repo/smem/tags"
-UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
-
-S = "${WORKDIR}/${BPN}-${HG_CHANGESET}"
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} smemcap.c -o smemcap
-}
-
-do_install() {
- install -d ${D}/${bindir}/
- install -d ${D}/${mandir}/man8
- install -m 0755 ${S}/smem ${D}${bindir}/
- sed -i -e '1s,#!.*python.*,#!${USRBINPATH}/env python3,' ${D}${bindir}/smem
- install -m 0755 ${S}/smemcap ${D}${bindir}/
- install -m 0644 ${S}/smem.8 ${D}/${mandir}/man8/
-}
-
-RDEPENDS_${PN} = "python3-core python3-compression"
-RRECOMMENDS_${PN} = "python3-matplotlib python3-numpy"
-
-PACKAGE_BEFORE_PN = "smemcap"
-
-FILES_smemcap = "${bindir}/smemcap"
-
-BBCLASSEXTEND = "native"