aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2021-03-06 21:58:26 -0500
committerKhem Raj <raj.khem@gmail.com>2021-03-06 21:40:35 -0800
commitc64ab8ac63e1f7bddc9f709872ac61dc5775bd3a (patch)
tree4599fdcd5e5ae3879a839ce7cb681852da3586d1 /meta-oe/recipes-support
parent2642184903f6fc577da148ce9e5c6d82dd973137 (diff)
downloadmeta-openembedded-c64ab8ac63e1f7bddc9f709872ac61dc5775bd3a.tar.gz
gperftools: upgrade 2.8.1 -> 2.9.1
Add perl modules, sort RDEPENDS and add a description. Add curl as RDPENDS since it's needed by pprof. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb (renamed from meta-oe/recipes-support/gperftools/gperftools_2.8.1.bb)15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.8.1.bb b/meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb
index 2a386086f5..97942278db 100644
--- a/meta-oe/recipes-support/gperftools/gperftools_2.8.1.bb
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.9.1.bb
@@ -1,5 +1,10 @@
SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
HOMEPAGE = "https://github.com/gperftools/gperftools"
+DESCRIPTION = "The gperftools, previously called google-perftools, package contains some \
+utilities to improve and analyze the performance of C++ programs. \
+Included are an optimized thread-caching malloc() and cpu and heap profiling utilities. \
+"
+
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
@@ -44,7 +49,15 @@ FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/l
# pprof tool requires Getopt::long and POSIX perl5 modules.
# Also runs `objdump` on each cpuprofile data file
-RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
+RDEPENDS_${PN} += " \
+ binutils \
+ curl \
+ perl-module-carp \
+ perl-module-cwd \
+ perl-module-getopt-long \
+ perl-module-overloading \
+ perl-module-posix \
+"
RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"