aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-04-06 18:56:07 -0700
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:00 -0700
commitd4cde5cb305a71e519583383cb40a96133216d6b (patch)
tree2a2e2c85e68a2d4e1bd9206ab0985fc33efa3027 /meta-oe/recipes-support
parentd34fc2a563e13d44768b7ae98f30530a8ea6a9ad (diff)
downloadmeta-openembedded-d4cde5cb305a71e519583383cb40a96133216d6b.tar.gz
libtinyxml2: update 2.2.0 -> 3.0.0
Also misc recipe cleanup, take license text from tinyxml2.cpp source file instead of using the entire readme.md, and build using cmake. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb15
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb37
2 files changed, 15 insertions, 37 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb
new file mode 100644
index 0000000000..af0b785a69
--- /dev/null
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_3.0.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs"
+HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/"
+SECTION = "libs"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://tinyxml2.cpp;endline=22;md5=c19221dbd8a66ad3090462af4c5de5e7"
+
+SRC_URI = "git://github.com/leethomason/tinyxml2.git"
+
+SRCREV = "1977a7258cc66fd4da7f1e9da05a4933646a7803"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb
deleted file mode 100644
index 6ca6f7cbf0..0000000000
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs."
-HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/"
-LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://readme.md;md5=0033b2f8a25283414b21354670bb1334"
-SECTION = "libs"
-
-SRCREV = "d211bb13512cf4edb408e2c4badbcf4100ce0fd0"
-
-PV = "2.2.0+git${SRCPV}"
-
-SRC_URI = "git://github.com/leethomason/tinyxml2.git"
-
-S = "${WORKDIR}/git"
-
-EXTRA_CXXFLAGS = "-I. -fPIC"
-
-do_compile() {
- ${CXX} ${CXXFLAGS} ${EXTRA_CXXFLAGS} -c -o tinyxml2.o tinyxml2.cpp
- ${CXX} ${CXXFLAGS} \
- -shared \
- -Wl,-soname,libtinyxml2.so.${PV} \
- -o libtinyxml2.so.${PV} \
- ${LDFLAGS} \
- tinyxml2.o
-}
-
-do_install() {
- install -d ${D}${libdir}
- install -m 0755 ${S}/libtinyxml2.so.${PV} ${D}${libdir}
- ln -sf libtinyxml2.so.${PV} ${D}${libdir}/libtinyxml2.so
-
- install -d ${D}${includedir}
- install -m 0644 ${S}/tinyxml2.h ${D}${includedir}
-}
-
-BBCLASSEXTEND += "native"
-