aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorWilliam A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org>2019-03-26 19:30:00 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-28 09:48:30 -0700
commit07ee1b38f6e92f66de71286f43939f68ae79ecec (patch)
tree673426fa12f18b7ce84dc1924b88de5cab88f9b3 /meta-oe/recipes-support
parent478c35bc015c4bff9a805a6cafbf2f2cf38284f8 (diff)
downloadmeta-openembedded-07ee1b38f6e92f66de71286f43939f68ae79ecec.tar.gz
function2: Add package
function2 is an improved, drop in replacement for std::function. Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/function2/function2_4.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/function2/function2_4.0.0.bb b/meta-oe/recipes-support/function2/function2_4.0.0.bb
new file mode 100644
index 0000000000..556a25aa14
--- /dev/null
+++ b/meta-oe/recipes-support/function2/function2_4.0.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Improved drop-in replacement for std::function"
+DESCRIPTION = "Provides improved implementations of std::function."
+HOMEPAGE = "https://naios.github.io/function2"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+SRCREV = "d2acdb6c3c7612a6133cd03464ef941161258f4e"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/Naios/function2"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+# Installs some data to incorrect top-level /usr directory
+do_install_append() {
+ mkdir -p ${D}/${datadir}/function2
+ mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
+ mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
+}