aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-22 23:28:35 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-16 08:15:34 -0700
commitd210e225b45a3bfe805780d557bed384bba4716a (patch)
tree6d64a3924631e2e538f5f2c59c9beb8e347e7310 /meta-oe/recipes-support
parenta6d674b089ece172dce4cb2e5bc5f4f4498f4bae (diff)
downloadmeta-openembedded-d210e225b45a3bfe805780d557bed384bba4716a.tar.gz
ne10, libopus: add armv7ve override as well
* fix the override in packagegroup-meta-oe.bb * alllow building ne10 for armv7ve (e.g. Cortex-A15) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 4e8986de18..f37ccde1cb 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -15,13 +15,15 @@ PV .= "gitr+${SRCPV}"
inherit cmake
-# Incompatible with archs other than armv7 and aarch64
+# Incompatible with archs other than armv7, armv7ve and aarch64
COMPATIBLE_MACHINE = "(^$)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
COMPATIBLE_MACHINE_armv7a = "(.*)"
+COMPATIBLE_MACHINE_armv7ve = "(.*)"
NE10_TARGET_ARCH = ""
NE10_TARGET_ARCH_aarch64 = "aarch64"
NE10_TARGET_ARCH_armv7a = "armv7"
+NE10_TARGET_ARCH_armv7ve = "armv7"
EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'