aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
diff options
context:
space:
mode:
authorAnastasios Kavoukis <anastasios.kavoukis@arm.com>2021-07-28 20:19:16 +0100
committerArmin Kuster <akuster808@gmail.com>2021-08-01 09:28:45 -0700
commit24e01c99c4a06a5281fb80a648729c9b9add3091 (patch)
tree636b4a859cf3bb0281fc79ca6050324d6a8dfd70 /meta-oe/recipes-test/pm-qa/pm-qa_git.bb
parentb97e6c971639072f3866e26218505e390fd26cae (diff)
downloadmeta-openembedded-24e01c99c4a06a5281fb80a648729c9b9add3091.tar.gz
pm-qa: fix paths for shell scripts
A commit in the repo of pm-qa: "adf9df9 Fix path to library files and change shebang line" Changed the text that sed was using to replace relative to absolute paths. As a result sed was not effectively finding the text "source ../include" to replace it, as the sed should be now searching for ". ../include". Similarly for "../Switches" Signed-off-by: Anastasios Kavoukis <anastasios.kavoukis@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 06a93a04efe2c2cbae6de93d07962be4dfa35019) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/pm-qa/pm-qa_git.bb')
-rw-r--r--meta-oe/recipes-test/pm-qa/pm-qa_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
index 7e9971ea4c..bb641437c9 100644
--- a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
+++ b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
@@ -42,6 +42,7 @@ do_install () {
do
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}
+ sed -i -e 's#. ..\/Switches#${bindir}#g' ${script}
script_basename=`basename ${script}`
install -m 0755 $script ${D}${libdir}/${BPN}/${script_basename}
@@ -54,7 +55,7 @@ do_install () {
# if the script includes any helper scripts from the $libdir
# directory then change the source path to the absolute path
# to reflect the install location of the helper scripts.
- sed -i -e "s#source ../include#source ${libdir}/${BPN}#g" ${script}
+ sed -i -e "s#. ../include#. ${libdir}/${BPN}#g" ${script}
# Remove hardcoded relative paths
sed -i -e 's#..\/utils\/##' ${script}