aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-30 20:41:11 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-30 20:41:11 +0200
commit22c813fa4ba26f39f8814eaf32a030ee59a35f00 (patch)
treeae5460a5088d6d36da306fe78c5bd8efe7436173 /meta-oe
parent2c5c9e005bbef135c0b674d3166da7fef856849d (diff)
downloadmeta-openembedded-22c813fa4ba26f39f8814eaf32a030ee59a35f00.tar.gz
systemd: fix postinst so u-a can run offline
otherwise we don't get an /sbin/init.... Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index ba57a0239a..f6c675273e 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r3"
+PR = "r4"
inherit autotools vala update-alternatives
@@ -101,11 +101,12 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
# u-a for runlevel and telinit
pkg_postinst_${PN} () {
-# can't do this offline
+# can't do this offline, but we need the u-a bits
if [ "x$D" != "x" ]; then
- exit 1
+ echo "can't do addgroup offline"
+else
+ grep "^lock:" /etc/group > /dev/null || addgroup lock
fi
-grep "^lock:" /etc/group > /dev/null || addgroup lock
update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300