aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-06-06 15:56:46 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-08 08:31:34 +0200
commit9e0a8f915fab095ccbee567dc4e713e3cc20a287 (patch)
tree6bd716925968102cf107010240452c8d0671f4ad /meta-oe
parentd8846a9fdeaa22ade2a0938081e2c4102521076d (diff)
downloadmeta-openembedded-9e0a8f915fab095ccbee567dc4e713e3cc20a287.tar.gz
check: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/check/check_0.9.5.bb20
-rw-r--r--meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch18
-rw-r--r--meta-oe/recipes-support/check/files/configure_fix.patch12
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/check/check_0.9.5.bb b/meta-oe/recipes-support/check/check_0.9.5.bb
new file mode 100644
index 0000000000..132b563a21
--- /dev/null
+++ b/meta-oe/recipes-support/check/check_0.9.5.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "a unit test framework for C"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
+PRIORITY = "optional"
+SECTION = "devel"
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/check/check-${PV}.tar.gz \
+ file://configure_fix.patch \
+ file://check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch \
+ "
+S = "${WORKDIR}/check-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-plain-docdir"
+
+SRC_URI[md5sum] = "30143c7974b547a12a7da47809a90951"
+SRC_URI[sha256sum] = "961b3c66869018d02226bbbc394e79362cd898962ce810bce8417b3c497f7ad6"
diff --git a/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch b/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch
new file mode 100644
index 0000000000..61bdf1d42a
--- /dev/null
+++ b/meta-oe/recipes-support/check/files/check-m4-am-path-check-use-quadrigraphs-in-macro-names-to-unbreak-autoconf.patch
@@ -0,0 +1,18 @@
+Imported from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=395466
+
+-Khem
+Index: check-0.9.5/check.m4
+===================================================================
+--- check-0.9.5.orig/check.m4
++++ check-0.9.5/check.m4
+@@ -4,8 +4,8 @@ dnl
+
+ AC_DEFUN([AM_PATH_CHECK],
+ [
+- AC_MSG_WARN([[AM_PATH_CHECK() is deprecated]])
+- AC_MSG_WARN([[use PKG_CHECK_MODULES([CHECK], [check >= 0.9.4]) instead]])
++ AC_MSG_WARN([A@&t@M_PATH_CHECK() is deprecated])
++ AC_MSG_WARN([[use P@&t@KG_CHECK_MODULES([CHECK], [check >= 0.9.4]) instead]])
+ AC_ARG_WITH([check],
+ [ --with-check=PATH prefix where check is installed [default=auto]])
+
diff --git a/meta-oe/recipes-support/check/files/configure_fix.patch b/meta-oe/recipes-support/check/files/configure_fix.patch
new file mode 100644
index 0000000000..3e79319d80
--- /dev/null
+++ b/meta-oe/recipes-support/check/files/configure_fix.patch
@@ -0,0 +1,12 @@
+Index: check-0.9.5/configure.ac
+===================================================================
+--- check-0.9.5.orig/configure.ac 2008-10-29 04:09:50.000000000 +0000
++++ check-0.9.5/configure.ac 2008-10-29 04:10:06.000000000 +0000
+@@ -71,6 +71,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_LIBTOOL
++AM_PROG_CC_C_O
+ if test -n "$GCC"; then
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
+ fi