aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-29 20:32:56 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-30 13:54:49 +0200
commitc1111466bd1307f810c4494573bb28f924dceda4 (patch)
tree859462bd4c388c6cb9b092f33037c751497d6b1b /meta-oe
parent7aa7dd55db8db6ec350c743ce42eb469395a3208 (diff)
downloadmeta-openembedded-c1111466bd1307f810c4494573bb28f924dceda4.tar.gz
udev 171: cleanup duplicated rules some more
Install only upstream rules and the touchscreen0 symlink rule That gets us to: root@beagleboard-c3:~# time (udevadm trigger ; udevadm settle) real 0m1.540s user 0m0.062s sys 0m0.273s Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/udev/udev/touchscreen.rules18
-rw-r--r--meta-oe/recipes-core/udev/udev_171.bb16
2 files changed, 21 insertions, 13 deletions
diff --git a/meta-oe/recipes-core/udev/udev/touchscreen.rules b/meta-oe/recipes-core/udev/udev/touchscreen.rules
new file mode 100644
index 0000000000..d83fd1673d
--- /dev/null
+++ b/meta-oe/recipes-core/udev/udev/touchscreen.rules
@@ -0,0 +1,18 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Create a symlink to any touchscreen input device
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
+SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="ads7846", SYMLINK+="input/touchscreen0"
diff --git a/meta-oe/recipes-core/udev/udev_171.bb b/meta-oe/recipes-core/udev/udev_171.bb
index 05b7bec603..612da1062a 100644
--- a/meta-oe/recipes-core/udev/udev_171.bb
+++ b/meta-oe/recipes-core/udev/udev_171.bb
@@ -20,7 +20,7 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS = "gperf-native usbutils acl glib-2.0"
SRCREV = "${PV}"
-PR = "r0"
+PR = "r1"
# version specific SRC_URI
SRC_URI = "git://git.kernel.org/pub/scm/linux/hotplug/udev.git;protocol=git \
@@ -31,10 +31,7 @@ SRC_URI[sha256sum] = "1d5c548d7c85d30b3508b82ad88d853e28dddb6c526d0e67aa92ac18af
# generic SRC_URI
SRC_URI += " \
- file://mount.sh \
- file://mount.blacklist \
- file://network.sh \
- file://local.rules \
+ file://touchscreen.rules \
file://default \
file://init \
file://cache \
@@ -103,20 +100,13 @@ do_install () {
install -d ${D}${sysconfdir}/default
install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/udev
- cp ${S}/rules/rules.d/* ${D}${sysconfdir}/udev/rules.d/
-
- install -m 0644 ${WORKDIR}/mount.blacklist ${D}${sysconfdir}/udev/
- install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
+ install -m 0644 ${WORKDIR}/touchscreen.rules ${D}${sysconfdir}/udev/rules.d/touchscreen.rules
touch ${D}${sysconfdir}/udev/saved.uname
touch ${D}${sysconfdir}/udev/saved.cmdline
touch ${D}${sysconfdir}/udev/saved.devices
touch ${D}${sysconfdir}/udev/saved.atags
- install -d ${D}${sysconfdir}/udev/scripts/
-
- install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
- install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
}
# Create the cache after checkroot has run