aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-03-20 13:33:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 15:38:26 +0200
commit6291199ee4c9dde2ac05e1d48372c667f92b14ff (patch)
treeda49248b5f706cb839f65a541ee6cb053dd7ed0a /meta-oe
parent40e0f371f3eb1628655c484feac0cebf810737b4 (diff)
downloadmeta-openembedded-6291199ee4c9dde2ac05e1d48372c667f92b14ff.tar.gz
bash-completion: fix 'files already exist' WARNING message
Some bash completion commands are already provided by util-linux recipe. Also disable parallel build because "symlinks" rule is buggy (see completions/Makefile.am). Signed-off-by: Matthieu CRAPET <Matthieu.CRAPET@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
index 411b9b7e17..014d122cb6 100644
--- a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
@@ -5,6 +5,8 @@ BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+PR = "r1"
+
SECTION = "console/utils"
SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
@@ -12,11 +14,19 @@ SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
SRC_URI[md5sum] = "0d903f398be8c8f24bc5ffa6f86127f8"
SRC_URI[sha256sum] = "e5a490a4301dfb228361bdca2ffca597958e47dd6056005ef9393a5852af5804"
+PARALLEL_MAKE = ""
+
inherit allarch autotools
do_install_append() {
install -d ${D}${sysconfdir}/bash_completion.d/
echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
+
+ # Delete files already provided by util-linux
+ local i
+ for i in cal dmesg hwclock ionice look renice rtcwake; do
+ rm ${D}${datadir}/${BPN}/completions/$i
+ done
}
RDEPENDS_${PN} = "bash"