aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAlex Yao <alexyao1@meraki.com>2023-05-01 11:38:52 -0700
committerArmin Kuster <akuster808@gmail.com>2023-05-05 07:20:59 -0400
commiteca75eba7d34612abe2234ea5bfd91a8b157c846 (patch)
treec9a41715f9b0c0d7d821e86301027c9eb652217f /meta-oe
parent765cfa779db64fc5b71faef1e78f902fa5c200d0 (diff)
downloadmeta-openembedded-eca75eba7d34612abe2234ea5bfd91a8b157c846.tar.gz
lcov: Fix Perl Path
Fixes an issue where lcov is using the system Perl rather than the yocto provided Perl. This causes packages to not be found during runtime such as PerlIO::gzip. Signed-off-by: Alex Yao <alexyao1@meraki.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rwxr-xr-xmeta-oe/recipes-support/lcov/lcov_1.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/lcov/lcov_1.14.bb b/meta-oe/recipes-support/lcov/lcov_1.14.bb
index 0cc8b31b3f..5e8fb938cf 100755
--- a/meta-oe/recipes-support/lcov/lcov_1.14.bb
+++ b/meta-oe/recipes-support/lcov/lcov_1.14.bb
@@ -59,7 +59,7 @@ SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
do_install() {
- oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
+ oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir} LCOV_PERL_PATH="/usr/bin/env perl"
}
BBCLASSEXTEND = "native nativesdk"