aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2020-03-27 11:54:12 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-27 01:47:53 -0700
commit989e57d10860df920eaf44b2079ae5c86041090c (patch)
tree7f7772301d713fef9435962cb0882357f46c5708 /meta-oe
parent525f1c4ade8774ec8c8a6a0045a6860574220335 (diff)
downloadmeta-openembedded-989e57d10860df920eaf44b2079ae5c86041090c.tar.gz
turbostat: Fix build failure for missing kernel internal heaers and clean up
To fix the following build failures turbostat.c:(.text+0xc28a): undefined reference to `UL' turbostat.c:33:10: fatal error: sys/capability.h: No such file or directory (for kernel v5.6-rc7) - Add dependency on libcap for kernel v5.6-rc7 and later versions - Copy internal linux/const.h used by previously added internal linux/bits.h - Tweak linux/const.h to allow it to refer to uapi const.h, as linux-libc-headers purposely removes _UAPI from the locker macros of the headers - Remove -I for kernel-source in EXTRA_OEMAKE, as linux-kernel-headers has provided enough and necessary headers - Make do_configure depend on kernel's do_shared_workdir Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
index 5f6588de5f..60040a47af 100644
--- a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
+++ b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
@@ -21,7 +21,7 @@ SRC_URI += "\
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-DEPENDS = "virtual/kernel"
+DEPENDS = "libcap"
# This looks in S, so we better make sure there's
# something in the directory.
@@ -30,25 +30,28 @@ do_populate_lic[depends] = "${PN}:do_configure"
EXTRA_OEMAKE = '\
- CC="${CC}" \
- 'CFLAGS=-Wall -I${STAGING_KERNEL_DIR}/arch/x86/include/uapi ${LDFLAGS}' \
+ CC="${CC}" 'CFLAGS=-Wall ${LDFLAGS}' \
'
# If we build under STAGING_KERNEL_DIR, source will not be put
# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
# do_configure() is invoked so we can safely copy from it.
#
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
do_configure_prepend() {
mkdir -p ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
+ cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
cp -r ${WORKDIR}/COPYING ${S}
}
do_compile() {
sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h
+ sed -i 's#<linux/const.h>#"const.h"#' bits.h
+ sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile