aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-22 19:59:37 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-23 07:55:12 +0100
commit0658069375e9dfe8c6b5e93b578ca56efaad6512 (patch)
tree0b5c9a3efff7a6671f13b73633f61244ab9553b4 /meta-oe
parent815124f28e80b00230f820d663966af3423e210b (diff)
downloadmeta-openembedded-0658069375e9dfe8c6b5e93b578ca56efaad6512.tar.gz
systemd-serialgetty: replace ${base_libdir}/systemd by ${systemd_unitdir} set in oe-core
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-serialgetty.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
index 5b903a08c0..5dd9e823db 100644
--- a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb
@@ -26,12 +26,12 @@ def get_console(d):
do_install() {
if [ ! ${@get_baudrate(d)} = "" ]; then
sed -i -e s/\@BAUDRATE\@/${@get_baudrate(d)}/g ${WORKDIR}/serial-getty@.service
- install -d ${D}${base_libdir}/systemd/system/
+ install -d ${D}${systemd_unitdir}/system/
install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/
- install ${WORKDIR}/serial-getty@.service ${D}${base_libdir}/systemd/system/
+ install ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/
# enable the service
- ln -sf ${base_libdir}/systemd/system/serial-getty@.service \
+ ln -sf ${systemd_unitdir}/system/serial-getty@.service \
${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(d)}.service
fi
}
@@ -42,5 +42,5 @@ RRECOMMENDS_${PN} = ""
RDEPENDS_${PN} = "systemd"
# This is a machine specific file
-FILES_${PN} = "${base_libdir}/systemd/system/serial-getty@.service ${sysconfdir}"
+FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
PACKAGE_ARCH = "${MACHINE_ARCH}"