aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-09 10:13:52 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:38 -0700
commit0c7d54b58efb6fc21077dc9cf8aca361f8e24746 (patch)
tree191473b8b182d1359c34c1bbf8ceba6bd4a19eef /meta-oe
parent2f7c7f82c8c46cee222dea4208de7652e6fceb5c (diff)
downloadmeta-openembedded-0c7d54b58efb6fc21077dc9cf8aca361f8e24746.tar.gz
cherokee: complete systemd native support
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
index 93bb1913eb..0080195dee 100644
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -5,7 +5,7 @@ SECTION = "network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r1"
+PR = "r3"
DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -15,7 +15,7 @@ SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar
SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
-inherit autotools pkgconfig binconfig update-rc.d
+inherit autotools pkgconfig binconfig update-rc.d systemd
EXTRA_OECONF = "--disable-static \
--disable-nls \
@@ -26,9 +26,6 @@ do_install_append () {
install -m 0755 -d ${D}${sysconfdir}/init.d
install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
- install -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/
-
# clean up .la files for plugins
rm -f ${D}${libdir}/cherokee/*.la
}
@@ -36,7 +33,6 @@ do_install_append () {
# Put -dev near the front so we can move the .la files into it with a wildcard
PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
-FILES_${PN} += "${base_libdir}/systemd"
FILES_cget = "${bindir}/cget"
FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
@@ -49,3 +45,6 @@ CONFFILES_${PN} = " \
INITSCRIPT_NAME = "cherokee"
INITSCRIPT_PARAMS = "defaults 91 91"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "cherokee.service"