aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-01 09:20:23 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-06-05 10:46:48 +0200
commit44b20b0267289c3eebcf23ccde679000d11510dd (patch)
tree3a55ca698c1199abd2523e30edd13d26ec96e72c /meta-oe
parent0b87ade4ac1d4d0b43274fb4ad6f95a793d9d129 (diff)
downloadmeta-openembedded-44b20b0267289c3eebcf23ccde679000d11510dd.tar.gz
systemd-systemctl-native: Add additional messages for better debugging
These messages helped me to fix the breakage of networkmanager/systemd Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl5
2 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
index 78eb8f36bb..7ca77ae18a 100644
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r2"
+PR = "r3"
inherit native
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
index 6e7a05d349..ff9e6a7512 100755
--- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -1,4 +1,5 @@
#!/bin/sh
+echo "Started $0 $*"
ROOT=
@@ -42,6 +43,7 @@ while [ $# != 0 ]; do
done
for service in $services; do
+ echo "Try to find location of $service..."
# find service file
for p in $ROOT/etc/systemd/system \
$ROOT/lib/systemd/system \
@@ -55,6 +57,7 @@ for service in $services; do
echo "'$service' couldn't be found; exiting with error"
exit 1
fi
+ echo "Found $service in $service_file"
# create the required symbolic links
wanted_by=$(grep WantedBy $ROOT/$service_file \
@@ -63,6 +66,7 @@ for service in $services; do
| grep '\.target$')
for r in $wanted_by; do
+ echo "WantedBy=$r found in $service"
if [ "$action" = "enable" ]; then
mkdir -p $ROOT/etc/systemd/system/$r.wants
ln -s $service_file $ROOT/etc/systemd/system/$r.wants
@@ -79,6 +83,7 @@ for service in $services; do
| sed 's,Also=,,g' \
| tr ',' '\n')
for a in $also; do
+ echo "Also=$a found in $service"
if [ "$action" = "enable" ]; then
$0 --root=$ROOT enable $a
fi