aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 23:22:55 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-30 09:50:19 +0100
commit73e16796802616c78ec9c3268fa030b497243a73 (patch)
treea13c14760163c6373b0a1cbba598535bf81a6831 /meta-oe
parentff3e844f6923e09f867adfae95f2143b50e3e656 (diff)
downloadmeta-openembedded-73e16796802616c78ec9c3268fa030b497243a73.tar.gz
iotop: add from OE-Classic, update and tidy up
* Update to 0.4.4, adjusting python module dependencies as appropriate * Add SUMMARY and DESCRIPTION * Add LIC_FILES_CHKSUM * Make LICENSE more accurate * Fix unpackaged directory warning Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.4.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
new file mode 100644
index 0000000000..8be41af41b
--- /dev/null
+++ b/meta-oe/recipes-extended/iotop/iotop_0.4.4.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Simple top-like I/O monitor"
+DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
+ It watches I/O usage information output by the Linux kernel and displays \
+ a table of current I/O usage by processes on the system."
+HOMEPAGE = "http://guichaz.free.fr/iotop/"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
+
+SRC_URI = "http://guichaz.free.fr/iotop/files/${PN}-${PV}.tar.bz2"
+SRC_URI[md5sum] = "cdd38b276cbf238676f5d2bcf098ba9c"
+SRC_URI[sha256sum] = "46f3279fb1a7dfc129b5d00950c6e8389e4aedeb58880e848b88d686483df0b0"
+
+inherit distutils
+
+do_install_append() {
+ rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo
+ rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
+ [ -d ${D}${datadir}/share ] && rmdir ${D}${datadir}/share
+}
+
+RDEPENDS_${PN} = "python-distutils python-curses python-textutils \
+ python-codecs python-ctypes python-pprint \
+ python-shell"