aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-03-08 21:15:31 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-09 07:50:37 +0100
commit8b5006510a73d04f023554b2126b0858f7bbd68a (patch)
tree5e33e80557fc667c0bde3b04c2acc18ce12043fa /meta-oe
parent47ba455a110db200170c227263467685c382094b (diff)
downloadmeta-openembedded-8b5006510a73d04f023554b2126b0858f7bbd68a.tar.gz
udev-173: don't hardcode path to pidof
* pidof lives in /bin, search it in $PATH. * Assume pidof's presence. * Remove -e shell option, because pidof may return nonzero. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/udev/udev/init8
-rw-r--r--meta-oe/recipes-core/udev/udev_173.bb2
2 files changed, 4 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/udev/udev/init b/meta-oe/recipes-core/udev/udev/init
index ecc357d4fe..d160300abd 100644
--- a/meta-oe/recipes-core/udev/udev/init
+++ b/meta-oe/recipes-core/udev/udev/init
@@ -1,4 +1,4 @@
-#!/bin/sh -e
+#!/bin/sh
### BEGIN INIT INFO
# Provides: udev
@@ -18,10 +18,8 @@ export TZ=/etc/localtime
[ -f /etc/udev/udev.conf ] && . /etc/udev/udev.conf
kill_udevd() {
- if [ -x /sbin/pidof ]; then
- pid=`/sbin/pidof -x udevd`
- [ -n "$pid" ] && kill $pid
- fi
+ pid=`pidof -x udevd`
+ [ -n "$pid" ] && kill $pid
}
export ACTION=add
diff --git a/meta-oe/recipes-core/udev/udev_173.bb b/meta-oe/recipes-core/udev/udev_173.bb
index 5c5ce26b26..b7d7ed3d88 100644
--- a/meta-oe/recipes-core/udev/udev_173.bb
+++ b/meta-oe/recipes-core/udev/udev_173.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
# Needed for udev-extras
DEPENDS = "gperf-native usbutils acl glib-2.0"
-PR = "r3"
+PR = "r4"
# version specific SRC_URI
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \