aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-02-08 12:50:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-24 10:55:49 +0100
commit9cca08ee27f166395e500718bf184fa86112c224 (patch)
tree6100a9c2510961072a92c7ba374a5caeeb5a7181 /meta-oe
parentf75e91c48cfc58f91dc8f70f80a154d97d2d6c60 (diff)
downloadmeta-openembedded-9cca08ee27f166395e500718bf184fa86112c224.tar.gz
systemd: split out libraries from ${PN}
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index c1a0117735..4c458bd73c 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r15"
+PR = "r16"
inherit useradd pkgconfig autotools vala perlnative
@@ -59,6 +59,11 @@ do_install() {
ln -s ${base_bindir}/systemd ${D}/init
}
+python populate_packages_prepend (){
+ systemdlibdir = d.getVar("base_libdir", True)
+ do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)
+}
+
PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze"
USERADD_PACKAGES = "${PN}"
@@ -79,7 +84,7 @@ FILES_${PN}-vconsole-setup = "${base_libdir}/systemd/systemd-vconsole-setup \
RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts"
-FILES_${PN} += " ${base_bindir}/* \
+FILES_${PN} = " ${base_bindir}/* \
${datadir}/dbus-1/services \
${datadir}/dbus-1/system-services \
${datadir}/polkit-1 \
@@ -93,6 +98,11 @@ FILES_${PN} += " ${base_bindir}/* \
${bindir}/systemd* \
${libdir}/tmpfiles.d/*.conf \
${libdir}/systemd \
+ ${libdir}/binfmt.d \
+ ${libdir}/modules-load.d \
+ ${libdir}/sysctl.d \
+ ${localstatedir} \
+ ${libexecdir} \
"
FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debug ${base_libdir}/security/.debug/"