aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-02-23 15:48:14 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-23 16:46:32 +0100
commitaa26673c83a126732d9a404bbe748b7e5321009f (patch)
tree852ad6e2e629404a47d34e6e90d14eb1d4d9a385 /meta-oe
parentafa3939e99f87365feb4f55d727268a723e68c55 (diff)
downloadmeta-openembedded-aa26673c83a126732d9a404bbe748b7e5321009f.tar.gz
cloud9: use systemd_unitdir variable
* maybe we should move systemd_unitdir definition outside systemd.bbclass because it's used in few more recipes which doesn't inherit systemd Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
index 4e95075f88..7041527a40 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
DEPENDS = "libxml2 nodejs-native"
-PR = "r13"
+PR = "r14"
SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
@@ -98,8 +98,8 @@ do_install () {
install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js
install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node
- install -m 0755 -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/cloud9.service ${D}${base_libdir}/systemd/system/
+ install -m 0755 -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system/
install -m 0755 -d ${D}${sysconfdir}/avahi/services/
install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
@@ -109,7 +109,7 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o
${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \
"
-FILES_${PN} += "${base_libdir}/systemd/system"
+FILES_${PN} += "${systemd_unitdir}/system"
RDEPENDS_${PN} = "nodejs gzip"
inherit systemd