aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-02-28 14:14:09 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-28 15:49:59 +0100
commitdd44dc50adaaafd269fab18b09fa6d8b8f7a1759 (patch)
treef50612d206d0d6d953ea059ade57041cf02ee0f5 /meta-oe
parent11ab6e41b1131ea489e69c868ba2767201d39f93 (diff)
downloadmeta-openembedded-dd44dc50adaaafd269fab18b09fa6d8b8f7a1759.tar.gz
xinput-calibrator 0.7.5: fix calibration script
The 'auto' format switched to 'xorg.conf.d' which broke the script. The pointercal package also installed an 'empty' pointercal by default, which also broke the script. Fix these 2 in one go. Also remove the hal script since hal isn't supported in the oe-core universe anymore Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch56
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb6
2 files changed, 59 insertions, 3 deletions
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch
new file mode 100644
index 0000000000..8e6d9498e7
--- /dev/null
+++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch
@@ -0,0 +1,56 @@
+From e73eb2c343006865ff3faf7777ab93ccfd1762d6 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 28 Feb 2012 14:09:08 +0100
+Subject: [PATCH] xinput_calibrator_pointercal.sh: specify output type since 'auto' doesn't always pick 'xinput'
+
+Also deal with pointercal files that contain '# replace with valid machine specific pointercal.xinput'
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+
+Upstream-status: Submitted
+
+ scripts/xinput_calibrator_pointercal.sh | 22 +++++++++++++++-------
+ 1 files changed, 15 insertions(+), 7 deletions(-)
+
+diff --git a/scripts/xinput_calibrator_pointercal.sh b/scripts/xinput_calibrator_pointercal.sh
+index 579509c..fccb197 100755
+--- a/scripts/xinput_calibrator_pointercal.sh
++++ b/scripts/xinput_calibrator_pointercal.sh
+@@ -6,18 +6,26 @@
+ #
+ # original script: Martin Jansa <Martin.Jansa@gmail.com>, 2010-01-31
+ # updated by Tias Guns <tias@ulyssis.org>, 2010-02-15
++# updated by Koen Kooi <koen@dominion.thruhere.net>, 2012-02-28
++
++PATH="/usr/bin:$PATH"
+
+ BINARY="xinput_calibrator"
+ CALFILE="/etc/pointercal.xinput"
+ LOGFILE="/var/log/xinput_calibrator.pointercal.log"
+
+ if [ -e $CALFILE ] ; then
+- echo "Using calibration data stored in $CALFILE"
+- . $CALFILE
+-else
+- CALDATA=`$BINARY -v | tee $LOGFILE | grep ' xinput set' | sed 's/^ //g; s/$/;/g'`
+- if [ ! -z "$CALDATA" ] ; then
+- echo $CALDATA > $CALFILE
+- echo "Calibration data stored in $CALFILE (log in $LOGFILE)"
++ if grep replace $CALFILE ; then
++ echo "Empty calibration file found, removing it"
++ rm $CALFILE
++ else
++ echo "Using calibration data stored in $CALFILE"
++ . $CALFILE && exit 0
+ fi
+ fi
++
++CALDATA=`$BINARY --output-type xinput -v | tee $LOGFILE | grep ' xinput set' | sed 's/^ //g; s/$/;/g'`
++if [ ! -z "$CALDATA" ] ; then
++ echo $CALDATA > $CALFILE
++ echo "Calibration data stored in $CALFILE (log in $LOGFILE)"
++fi
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
index f0e85cfd8d..e39cc44b5a 100644
--- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
+++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb
@@ -4,11 +4,12 @@ LICENSE = "MIT-X"
LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=998e238a7638a7446eaeb02398f691fc"
DEPENDS = "virtual/libx11 libxi"
-PR = "r2"
+PR = "r3"
inherit autotools
-SRC_URI = "http://github.com/downloads/tias/xinput_calibrator/xinput_calibrator-${PV}.tar.gz"
+SRC_URI = "http://github.com/downloads/tias/xinput_calibrator/xinput_calibrator-${PV}.tar.gz \
+ file://0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch"
SRC_URI[md5sum] = "20da0a2055a5a75962add8c6b44f60fa"
SRC_URI[sha256sum] = "baa4ddca49ec94c27ba4c715bfa26692fec1132103e927213c3169e475d3d971"
@@ -20,7 +21,6 @@ EXTRA_OECONF += "--with-gui=x11"
do_install_append() {
install -d ${D}${bindir}
install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
- install -m 0755 scripts/xinput_calibrator_get_hal_calibration.sh ${D}${bindir}/xinput_calibrator_get_hal_calibration.sh
}
RDEPENDS_${PN} = "xinput"