aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMax Kellermann <max.kellermann@gmail.com>2018-02-07 11:15:45 +0100
committerArmin Kuster <akuster808@gmail.com>2020-12-14 21:25:32 -0800
commitf6338892d9c57c51ed48b04f587b468f7718a8ba (patch)
tree127ddc0aa0959ae3eaa26efe2c6860d01ee79dd9 /meta-oe
parentf7984364181f9bb4e20d15af9431bad54ebe861d (diff)
downloadmeta-openembedded-f6338892d9c57c51ed48b04f587b468f7718a8ba.tar.gz
php: remove the failing ${D}/${TMPDIR} code
Appending ${TMPDIR} to ${D} doesn't make any sense, because both are absolute paths. And additionally, the code fails: rmdir: failed to remove '/usr/src/oe/tmp-musl/work/core2-64-oe-linux-musl/php/7.1.9-r0/image//usr': Directory not empty Signed-off-by: Max Kellermann <max.kellermann@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/php/php_7.4.9.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/php/php_7.4.9.bb b/meta-oe/recipes-devtools/php/php_7.4.9.bb
index abd8b16723..1da5607835 100644
--- a/meta-oe/recipes-devtools/php/php_7.4.9.bb
+++ b/meta-oe/recipes-devtools/php/php_7.4.9.bb
@@ -155,7 +155,6 @@ do_install_prepend_class-target() {
# fixme
do_install_append_class-target() {
install -d ${D}${sysconfdir}/
- rm -rf ${D}/${TMPDIR}
rm -rf ${D}/.registry
rm -rf ${D}/.channels
rm -rf ${D}/.[a-z]*
@@ -179,14 +178,6 @@ do_install_append_class-target() {
${D}${systemd_unitdir}/system/php-fpm.service
fi
- TMP=`dirname ${D}/${TMPDIR}`
- while test ${TMP} != ${D}; do
- if [ -d ${TMP} ]; then
- rmdir ${TMP}
- fi
- TMP=`dirname ${TMP}`;
- done
-
if ${@bb.utils.contains('PACKAGECONFIG', 'apache2', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/apache2/modules.d
install -d ${D}${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION}