aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-04 17:45:56 +0200
committerArmin Kuster <akuster808@gmail.com>2021-10-08 17:23:52 -0700
commit65e15aeb90e666fd2ffd256a0123ba4f12b791be (patch)
tree0802fd172e3b146387c433db5672f45c782fc052 /meta-oe
parent2c097d9713c2116d27b91c231e7863c15b3918ba (diff)
downloadmeta-openembedded-65e15aeb90e666fd2ffd256a0123ba4f12b791be.tar.gz
lv-drivers: Add recipe for lvgl lib
Wayland driver is supported. Change-Id: If734c0f1037a1feeb08a2a67fa76e3142ae35af0 Forwarded: https://github.com/openembedded/meta-openembedded/pull/447 Origin: https://git.ostc-eu.org/OSTC/planning/core-os/-/issues/233 Relate-to: https://github.com/lvgl/lvgl/issues/2534 Signed-off-by: Philippe Coval <philippe.coval@huawei.com> (cherry picked from commit 5f69cfea691d3770012ba97c808567fe6e99cd4f) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
new file mode 100644
index 0000000000..a7478d4d5b
--- /dev/null
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -0,0 +1,45 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+# SPDX-License-Identifier: MIT
+
+# TODO: Pin upstream release (current v7.11.0-80-g419a757)
+src_org = "lvgl"
+SRC_URI = "gitsm://github.com/${src_org}/lv_drivers;destsuffix=${S};protocol=https;nobranch=1"
+SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
+
+HOMEPAGE = "https://docs.lvgl.io/latest/en/html/porting/index.html"
+SUMMARY = "LVGL's Display and Touch pad drivers"
+DESCRIPTION = "Collection of drivers: SDL, framebuffer, wayland and more..."
+
+DEPENDS += "libxkbcommon"
+DEPENDS += "lvgl"
+DEPENDS += "wayland"
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
+inherit cmake
+inherit features_check
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
+
+TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
+TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
+
+
+do_configure:append() {
+ [ -r "${S}/lv_drv_conf.h" ] \
+ || sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
+ -e "s|# define USE_WAYLAND 0|# define USE_WAYLAND 1|g" \
+ < "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h"
+}
+
+
+FILES:${PN}-dev = "\
+ ${includedir}/lvgl/lv_drivers/ \
+ "
+
+FILES:${PN}-staticdev = "${libdir}/"