aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMatteo Croce <mcroce@microsoft.com>2021-08-26 19:21:58 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-26 11:57:26 -0700
commit8d62db72656a76c198b43783dfbe530c6bdea382 (patch)
tree49a8043b5b8fa2aa2ec41a6c4a3146ad0d1125ae /meta-oe
parent53e5731207c41ecc06534697ec728b20682e22b0 (diff)
downloadmeta-openembedded-8d62db72656a76c198b43783dfbe530c6bdea382.tar.gz
libbpf: bump to 0.4.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-kernel/libbpf/libbpf/0001-install-don-t-preserve-file-owner.patch31
-rw-r--r--meta-oe/recipes-kernel/libbpf/libbpf_0.4.bb (renamed from meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb)9
2 files changed, 3 insertions, 37 deletions
diff --git a/meta-oe/recipes-kernel/libbpf/libbpf/0001-install-don-t-preserve-file-owner.patch b/meta-oe/recipes-kernel/libbpf/libbpf/0001-install-don-t-preserve-file-owner.patch
deleted file mode 100644
index 9423141962..0000000000
--- a/meta-oe/recipes-kernel/libbpf/libbpf/0001-install-don-t-preserve-file-owner.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 7df10d91db6f533cc0f6c09f4ae8ad92918c6160 Mon Sep 17 00:00:00 2001
-From: Matteo Croce <mcroce@microsoft.com>
-Date: Tue, 26 Jan 2021 12:41:47 +0100
-Subject: [PATCH] install: don't preserve file owner
-
-'cp -p' preserve file ownership, this may leave files owned by the
-current in user in /lib .
-
-Upstream-status: Submitted (0.4 release) [https://github.com/libbpf/libbpf/commit/767d82caab7e54238f2fc6f40ab1e4af285f2abe]
-
-Signed-off-by: Matteo Croce <mcroce@microsoft.com>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index da33613..ab66edc 100644
---- a/Makefile
-+++ b/Makefile
-@@ -130,7 +130,7 @@ define do_s_install
- $(Q)if [ ! -d '$(DESTDIR)$2' ]; then \
- $(INSTALL) -d -m 755 '$(DESTDIR)$2'; \
- fi;
-- $(Q)cp -fpR $1 '$(DESTDIR)$2'
-+ $(Q)cp -fR $1 '$(DESTDIR)$2'
- endef
-
- install: all install_headers install_pkgconfig
---
-2.29.2
-
diff --git a/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb b/meta-oe/recipes-kernel/libbpf/libbpf_0.4.bb
index 57e8376b5e..27df98c3e7 100644
--- a/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb
+++ b/meta-oe/recipes-kernel/libbpf/libbpf_0.4.bb
@@ -6,24 +6,21 @@ LICENSE = "LGPLv2.1+"
# There is a typo in the filename, LPGL should really be LGPL.
# Keep this until the correct name is set upstream.
-LIC_FILES_CHKSUM = "file://../LICENSE.LPGL-2.1;md5=b370887980db5dd40659b50909238dbd"
+LIC_FILES_CHKSUM = "file://../LICENSE.LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
DEPENDS = "zlib elfutils"
do_compile[depends] += "virtual/kernel:do_shared_workdir"
SRC_URI = "git://github.com/libbpf/libbpf.git;protocol=https"
-SRCREV = "051a4009f94d5633a8f734ca4235f0a78ee90469"
-
-# Backported from version 0.4
-SRC_URI += "file://0001-install-don-t-preserve-file-owner.patch"
+SRCREV = "db9614b6bd69746809d506c2786f914b0f812c37"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64).*-linux"
S = "${WORKDIR}/git/src"
-EXTRA_OEMAKE += "DESTDIR=${D} LIBDIR=${libdir}"
+EXTRA_OEMAKE += "DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
inherit pkgconfig