aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2013-12-05 15:10:38 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-21 19:16:51 +0100
commit5916ffe0a19422706d1f84870adc603bad202f1c (patch)
treec8f99d4813ea99f96254efefc1f47d8fd0c8834b /meta-oe
parent552b06192a48f0dfab59fb4894742e4415757dc2 (diff)
downloadmeta-openembedded-5916ffe0a19422706d1f84870adc603bad202f1c.tar.gz
mariadb-native: fix link error on Ubuntu 13.10
Below errors only occurs on Ubuntu 13.10: $arch-linux-libtool: link: g++ ... -o .libs/mysqltest_embedded \ ../../libmysqld/.libs/libmysqld.so -ldl ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlopen' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlclose' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlerror' ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlsym' GCC/ld verion on the host: gcc (Ubuntu/Linaro 4.8.1-10ubuntu8) 4.8.1 GNU ld (GNU Binutils for Ubuntu) 2.23.52.20130913 This is a strange behavior on Ub13.10, it fails even '-ldl' in the link command line. This patch will append '-ldl' to dependency_libs in libmysqld.la. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb3
-rw-r--r--meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch37
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
index a55c2ab6ae..e8382e285f 100644
--- a/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
+++ b/meta-oe/recipes-support/mysql/mariadb-native_5.1.67.bb
@@ -8,6 +8,9 @@ PACKAGES = ""
EXTRA_OEMAKE = ""
EXTRA_OECONF = " --with-embedded-server "
+SRC_URI += "file://fix-link-error-ub1310.patch \
+"
+
do_install() {
oe_runmake 'DESTDIR=${D}' install
mv -f ${D}${libdir}/mysql/* ${D}${libdir}
diff --git a/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch b/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch
new file mode 100644
index 0000000000..a528ea700a
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mariadb/fix-link-error-ub1310.patch
@@ -0,0 +1,37 @@
+mariadb-native: fix link error on Ubuntu 13.10
+
+Below errors only occurs on Ubuntu 13.10:
+
+$arch-linux-libtool: link: g++ ... -o .libs/mysqltest_embedded \
+ ../../libmysqld/.libs/libmysqld.so -ldl
+
+ ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlopen'
+ ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlclose'
+ ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlerror'
+ ../../libmysqld/.libs/libmysqld.so: undefined reference to `dlsym'
+
+GCC/ld verion on the host:
+ gcc (Ubuntu/Linaro 4.8.1-10ubuntu8) 4.8.1
+ GNU ld (GNU Binutils for Ubuntu) 2.23.52.20130913
+
+This is a strange behavior on Ub13.10, it fails even '-ldl' in the
+link command line. Below fix will append '-ldl' to dependency_libs
+in libmysqld.la.
+
+Upstream-Status: Submitted [https://mariadb.atlassian.net/browse/MDEV-5362]
+
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+================================================
+diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
+index 7a2c92e..eee501e 100644
+--- a/libmysqld/Makefile.am
++++ b/libmysqld/Makefile.am
+@@ -92,7 +92,7 @@ INC_LIB= $(top_builddir)/regex/libregex.la \
+ @ndbcluster_libs@ @NDB_SCI_LIBS@ \
+ @mysql_embedded_plugin_libs@ \
+ $(libevent_inc_libs) \
+- $(yassl_inc_libs)
++ $(yassl_inc_libs) @LIBDL@
+
+ if HAVE_YASSL
+ yassl_inc_libs= $(top_builddir)/extra/yassl/src/libyassl.la \