aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2017-08-24 15:40:10 +0300
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commit2130b25c677335f3cb160304133b7e4f14afa5ab (patch)
treeed3a9eebe1451f9160560eef15927b4e77b01e57 /meta-oe
parent44af8be65f2f1969df006eec08040f5ff81df790 (diff)
downloadmeta-openembedded-2130b25c677335f3cb160304133b7e4f14afa5ab.tar.gz
openldap: fix native LDFLAGS build error
LDFLAGS += "-pthread" adds the flag both for native and target builds, however the openldap-native build overwrites the variable inside native.bbclass causing "undefined reference to `pthread_getspecific'" and other linker errors. Change the append to happen after parsing by using the override syntax and thus make sure it executes after native.bbclass (bitbake -e reports pre-expansion value "${BUILD_LDFLAGS} -pthread"). Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 9d06ee2622bf2a7496b3e63a355f849e8496cacb) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.44.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
index 4b7ed35977..f5c233f2d5 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
@@ -150,7 +150,7 @@ PACKAGES += "${PN}-overlay-proxycache"
# it was disabled for cross-compiling.
CPPFLAGS_append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\' -fPIC"
-LDFLAGS += "-pthread"
+LDFLAGS_append = " -pthread"
do_configure() {
cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/ltmain.sh ${S}/build