aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:54 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commitf9ce43cdf6639acaa59d6144aabee798970ca3b6 (patch)
tree4cd53cb95eb5e514d834a65cdbdfa1d8739532c8 /meta-oe
parente5f01cae3885030f8b3c585e62e7dd7f84a278d9 (diff)
downloadmeta-openembedded-f9ce43cdf6639acaa59d6144aabee798970ca3b6.tar.gz
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb2
-rw-r--r--meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb2
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb2
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb2
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb2
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb6
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc2
9 files changed, 2 insertions, 20 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
index 303a032fb8..aeec195fa2 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/mercurial-${PV}"
inherit native
EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}"
+ PREFIX=${prefix}"
do_configure_append () {
sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
index a2747c3508..e203198af2 100644
--- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
+++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
@@ -24,8 +24,6 @@ EXTRA_OECMAKE = "-DLIB='${baselib}' \
-DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}"
do_configure_prepend() {
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
export STAGING_LIBDIR=${STAGING_LIBDIR}
export STAGING_INCDIR=${STAGING_INCDIR}
export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR}
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
index 86628b14bf..9848e5ac17 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -15,8 +15,6 @@ DEPENDS += "cups python libusb"
inherit autotools-brokensep python-dir pythonnative pkgconfig
-export BUILD_SYS
-export HOST_SYS
export STAGING_INCDIR
export STAGING_LIBDIR
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
index 52b271c114..af9633d406 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
@@ -39,8 +39,6 @@ EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
"
do_configure_prepend() {
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
export STAGING_INCDIR=${STAGING_INCDIR}
export STAGING_LIBDIR=${STAGING_LIBDIR}
}
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 73a5d0e5b2..a43e77029a 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -50,8 +50,6 @@ EXTRA_OECONF = " \
--disable-rpath \
"
-export BUILD_SYS
-export HOST_SYS
export STAGING_LIBDIR
export STAGING_INCDIR
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index aef9b138ab..6b883a87e3 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -55,9 +55,6 @@ do_compile_prepend() {
export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
-
- export BUILD_SYS="${BUILD_SYS}"
- export HOST_SYS="${HOST_SYS}"
}
do_install() {
@@ -65,9 +62,6 @@ do_install() {
export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
- export BUILD_SYS="${BUILD_SYS}"
- export HOST_SYS="${HOST_SYS}"
-
export DESTDIR="${D}"
# prefix is used for RPATH and DESTDIR/prefix for instalation
${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index eb38a5a6a4..83e7de8c0d 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -50,8 +50,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
inherit distutils-base pkgconfig cmake
-export BUILD_SYS
-export HOST_SYS
export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
export PYTHON="${STAGING_BINDIR_NATIVE}/python"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index 789512f9e0..961b9cba01 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -70,8 +70,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
inherit distutils-base pkgconfig cmake
-export BUILD_SYS
-export HOST_SYS
export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
export PYTHON="${STAGING_BINDIR_NATIVE}/python"
export JAVA_HOME="${STAGING_DIR_NATIVE}/usr/bin/java"
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index 288a2d183d..32ffe190b6 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -113,7 +113,7 @@ python populate_packages_prepend() {
do_configure() {
# do_configure_prepend
# make sure configure finds python includdirs with these envs
- export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ export \
STAGING_INCDIR=${STAGING_INCDIR} \
STAGING_LIBDIR=${STAGING_LIBDIR}