aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-11-16 17:10:12 -0800
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commit3fcf819224c33a5785ecbf198aa1da466865f798 (patch)
treeceb715a759dc9d337fb3b594c50fe916b33a9b77 /meta-oe
parentc8913de265ce8f6355ba1f56d034f6ac40596763 (diff)
downloadmeta-openembedded-3fcf819224c33a5785ecbf198aa1da466865f798.tar.gz
gpsd: add gpsdctl@.service for USB autoplug
This service allows gpsd to automatically recognize USB devices but is currently missing from our packaging. Without this service and the matching udev rules from upstream, gpsd will fail to recognize USB devices when they are plugged in. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
index 4c2e328e8a..41f01bb898 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -80,6 +80,7 @@ do_install_append() {
#support for systemd
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${S}/systemd/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
+ install -m 0644 ${S}/systemd/${BPN}ctl@.service ${D}${systemd_unitdir}/system/${BPN}ctl@.service
install -m 0644 ${S}/systemd/${BPN}.socket ${D}${systemd_unitdir}/system/${BPN}.socket
}
@@ -128,7 +129,7 @@ RDEPENDS_python-pygps = " \
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "${PN}.socket"
+SYSTEMD_SERVICE_${PN} = "${BPN}.socket ${BPN}ctl@.service"
ALTERNATIVE_${PN} = "gpsd-defaults"