aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-30 20:11:18 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:07:42 -0700
commit4469e270038583486488939ca2a08da8db37e555 (patch)
treef877c30a0e43feb0b4e21cc490be3ba58bed2a93 /meta-python/recipes-connectivity
parentb92b4031bdf7c8406fe92b80928966ba31a0767f (diff)
downloadmeta-openembedded-4469e270038583486488939ca2a08da8db37e555.tar.gz
python3-h2: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-h2/python-h2.inc12
-rw-r--r--meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb13
2 files changed, 11 insertions, 14 deletions
diff --git a/meta-python/recipes-connectivity/python-h2/python-h2.inc b/meta-python/recipes-connectivity/python-h2/python-h2.inc
deleted file mode 100644
index c457836b7c..0000000000
--- a/meta-python/recipes-connectivity/python-h2/python-h2.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "HTTP/2 State-Machine based protocol implementation"
-HOMEPAGE = "https://github.com/python-hyper/hyper-h2"
-LICENSE = "MIT"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b6b2f6bbe76528af543242d606c14851"
-
-SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
-SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
-
-inherit pypi
-
-RDEPENDS_${PN} += "${PYTHON_PN}-hpack ${PYTHON_PN}-hyperframe"
diff --git a/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb b/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
index 7230a27e8b..5d9a65530b 100644
--- a/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
+++ b/meta-python/recipes-connectivity/python-h2/python3-h2_3.1.1.bb
@@ -1,3 +1,12 @@
-require python-h2.inc
+DESCRIPTION = "HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE = "https://github.com/python-hyper/hyper-h2"
+LICENSE = "MIT"
-inherit setuptools3
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b6b2f6bbe76528af543242d606c14851"
+
+SRC_URI[md5sum] = "950b5a62a2a608dc4547a01edf99aa8f"
+SRC_URI[sha256sum] = "b8a32bd282594424c0ac55845377eea13fa54fe4a8db012f3a198ed923dc3ab4"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-hpack ${PYTHON_PN}-hyperframe"