aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-14 12:04:10 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-15 09:28:34 -0700
commite85ac5357d2f7b4f0febc87b7580bc2651a40197 (patch)
tree87cebbdf94a3286aeaaab256b37dafcbdfbb5e23 /meta-python/recipes-connectivity
parent433d887dbf8db849fb011ac8aa1e3ed8faa72b18 (diff)
downloadmeta-openembedded-e85ac5357d2f7b4f0febc87b7580bc2651a40197.tar.gz
python3-hyperframe: Upgrade 5.2.0 -> 6.0.0
Upgrade to release 6.0.0: API Changes (Backward-incompatible): - Introduce HyperframeError base exception class for all errors raised within hyperframe. - Change exception base class of UnknownFrameError to HyperframeError - Change exception base class of InvalidPaddingError to HyperframeError - Change exception base class of InvalidFrameError to HyperframeError - Invalid frames with wrong stream id (zero vs. non-zero) now raise InvalidDataError. - Invalid SETTINGS frames (non-empty but ACK) now raise InvalidDataError. - Invalid ALTSVC frames with non-bytestring field or origin now raise InvalidDataError. API Changes (Backward-compatible) - Deprecate total_padding - use pad_length instead. - Improve repr() output for all frame classes. - Introduce Frame.explain(data) for quick introspection of raw data. Bugfixes - Fixed padding parsing for PushPromiseFrame. - Fixed unchecked frame length for PriorityFrame. It now correctly raises InvalidFrameError. - Fixed promised stream id validation for PushPromiseFrame. It now raises InvalidDataError. - Fixed unchecked frame length for WindowUpdateFrame. It now correctly raises InvalidFrameError. - Fixed window increment value range validation. It now raises InvalidDataError. - Fixed parsing of SettingsFrame with mutual exclusion of ACK flag and payload. Other Changes - Removed support for Python 2.7, 3.4, 3.5, pypy. - Added support for Python 3.8. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_6.0.0.bb (renamed from meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb b/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_6.0.0.bb
index e5ef1ff38a..4a936b49af 100644
--- a/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_5.2.0.bb
+++ b/meta-python/recipes-connectivity/python-hyperframe/python3-hyperframe_6.0.0.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5bf1c68e73fbaec2b1687b7e71514393"
-SRC_URI[md5sum] = "6919183242feb26d8bce3b4cba81defd"
-SRC_URI[sha256sum] = "a9f5c17f2cc3c719b917c4f33ed1c61bd1f8dfac4b1bd23b7c80b3400971b41f"
+SRC_URI[md5sum] = "30136a712e092b1a45ae3cad3ae93131"
+SRC_URI[sha256sum] = "742d2a4bc3152a340a49d59f32e33ec420aa8e7054c1444ef5c7efff255842f1"
inherit pypi setuptools3