aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-09-20 22:37:12 +0000
committerKhem Raj <raj.khem@gmail.com>2018-09-24 11:49:45 -0700
commit16dbfded41b9ee772f8f56e85098e7589a8b25c5 (patch)
treeebcc4715e229ba332afcab8adf9561f584301411 /meta-python/recipes-connectivity
parenta427d6e9f1d6f8ef9cb7cf8b79da1938c6830a89 (diff)
downloadmeta-openembedded-16dbfded41b9ee772f8f56e85098e7589a8b25c5.tar.gz
python-thrift: set downloadfilename to prevent conflicts with thrift itself
* I was building thrift-0.9.3 from meta-oe and do_fetch was failing with wrong checksum because my premirror already had thrift-0.9.3.tar.gz from python-thrift, unpacking the archives to find what's wrong revealed what's wrong: thrift-0.9.3.old/thrift-0.9.3/: PKG-INFO setup.cfg setup.py src thrift.egg-info thrift-0.9.3/thrift-0.9.3/: aclocal appveyor.yml build CMakeLists.txt compiler config.guess config.hin configure contrib debian doap.rdf install-sh lib ltmain.sh Makefile.in NOTICE rat_exclude sonar-project.properties tutorial aclocal.m4 bower.json CHANGES compile composer.json config.h config.sub configure.ac CONTRIBUTING.md depcomp doc json-schema.json LICENSE Makefile.am missing package.json README.md test ylwrap you can get the same by comparing: http://mirror.switch.ch/mirror/apache/dist/thrift/0.9.3/thrift-0.9.3.tar.gz http://sources.openembedded.org/thrift-0.9.3.tar.gz the later is the python-thrift one from: http://git.openembedded.org/meta-openembedded/commit/?id=5cc904be9d6551f6e9a6465e990df1e2de940004 your premirror might already be polluted by this and thrift-0.10.0.tar.gz + thrift-0.11.0.tar.gz from: http://git.openembedded.org/meta-openembedded/commit/?id=c0416d417115fbae55d83c2d9fa3f3fca1a9e1a0 http://git.openembedded.org/meta-openembedded/commit/?id=960ae72e101d753b712e8bc40d8bdb4a0bcb0c5e * this should be backported all the way to morty where the conflicting archive was introduced and manual cleanup on sources.openembedded.org will be needed as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
index 8047ec77b9..10cff425e8 100644
--- a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
+++ b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.11.0.bb
@@ -7,6 +7,9 @@ SRC_URI[sha256sum] = "7d59ac4fdcb2c58037ebd4a9da5f9a49e3e034bf75b3f26d9fe48ba3d8
inherit pypi setuptools
+# Use different filename to prevent conflicts with thrift itself
+PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-logging \
${PYTHON_PN}-six \